1 reply [Last post]
OGirly
OGirly's picture
Offline
newbie
Ohio :(
Last seen: 9 years 13 weeks ago
Ohio :(
Timezone: GMT-5
Joined: 2011-02-21
Posts: 8
Points: 11

This really seems like it should be as simple as this:

This posts the info off a form that's collected from the $_POST data :\....errrr...this seems like it should be as simple as this....:
 
<?php include("includes/connection.php"); ?>
<?php include("includes/header.php"); ?>
<?php
date_default_timezone_set('UTC');
$postData1 = $_POST['blogTitle'];
$postData4 = $_POST['blogContent'];
$postData6 = $_POST['orgid'];
$postData5 = date('h:1:s A');
$postData2 = date('l jS \of F Y');
$postData3 = "tester";
mysql_query("INSERT INTO 'OGirly'" ."amandasBlogDatabase(entryNumber, blogTitle, postDate, author, blogContent, categoryId, orgid)"
."VALUES({$postData1}, {$postData2}, {$postData3}, {$postData4}, {$postData5}, {$postData6})"
);
 
?>
<a href="testform.php">Post Another Entry?</a>
<?php require("includes/footer.php"); ?>

...but it's not for some reason Sad. It only worked once, and although I never changed anything..it just stopped working..I'm so confused :\...maybe someone can catch something that I'm doing wrong that I can't seem to get...

jon19870
jon19870's picture
Offline
Enthusiast
Lancashire, England, UK
Last seen: 5 years 19 weeks ago
Lancashire, England, UK
Joined: 2007-01-05
Posts: 195
Points: 194

If you havent made any code

If you havent made any code changes and it was working before, it looks like there could be an issue connecting to the database to insert the data, have you checked th mySQL service is running? Try running something really simple such as reading all values from a table.