5 replies [Last post]
wonderland
wonderland's picture
Offline
Regular
Seattle
Last seen: 4 years 1 week ago
Seattle
Timezone: GMT-8
Joined: 2010-10-19
Posts: 20
Points: 28

my site has a lightbox when you click on a thumbnail here:

architecturalvisualisation3d.co.uk/portfolio/

The background of the lightbox is currently white, as is the background of the border once the image comes up. I'd like to change both.

Anyone know where the css file is located? and possibly which line/s of code?

Thanks.

Tony
Tony's picture
Offline
Moderator
Brisbane
Last seen: 23 hours 23 min ago
Brisbane
Timezone: GMT+10
Joined: 2003-03-12
Posts: 5342
Points: 2963

Hi wonderland,

Hi wonderland,
#fancybox-content in the file:
wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/static/fancybox/jquery.fancybox-1.3.4.min.css?ver=4.3.1

But you can and should override the style in one of your other stylesheets.

wonderland
wonderland's picture
Offline
Regular
Seattle
Last seen: 4 years 1 week ago
Seattle
Timezone: GMT-8
Joined: 2010-10-19
Posts: 20
Points: 28

Thanks for the response. Just

Thanks for the response. Just a follow up because it's still not working.

I saw an option to override the styles in the nextgen settings. Here's a screenshot (I used red #ff0000)

http://stayinwonderland.com/_issues/override.jpg

and I also did the same in the css file itself.

nothing is showing up as red.

Tony
Tony's picture
Offline
Moderator
Brisbane
Last seen: 23 hours 23 min ago
Brisbane
Timezone: GMT+10
Joined: 2003-03-12
Posts: 5342
Points: 2963

Hi wonderland, I think what

Hi wonderland,
I think what you want is:

#fancybox-content {
  background-color: #FF0000;
  border-color: #FF0000;
}

wonderland
wonderland's picture
Offline
Regular
Seattle
Last seen: 4 years 1 week ago
Seattle
Timezone: GMT-8
Joined: 2010-10-19
Posts: 20
Points: 28

Awesome. Almost there. The

Awesome. Almost there. The actual main background didn't change color so I inspected the element and saw that it was from a div Id 'fancybox-overlay' and so I changed it thusly:

#fancybox-overlay {
  background-color: #111;
}

which very clearly should work, but doesn't. Most peculiar.

wonderland
wonderland's picture
Offline
Regular
Seattle
Last seen: 4 years 1 week ago
Seattle
Timezone: GMT-8
Joined: 2010-10-19
Posts: 20
Points: 28

spent hours trying to change

spent hours trying to change that overlay. I think it's color is generated dynamically through JS.

Although I hardcoded the JS and tried to hardcode an override in the css but neither is working.