2 replies [Last post]
pwn
pwn's picture
Offline
newbie
Vienna
Last seen: 11 years 29 weeks ago
Vienna
Timezone: GMT+2
Joined: 2010-06-04
Posts: 8
Points: 13

Hello everybody,

here is my css code: http://codeviewer.org/view/code:f7d
here is the site i'm building: http://mariazell.conovio.com

If you open the page, you will see the following 3 things I cant understand

#1: in firefox the "veranstaltungen" box (#vbox in my css) is where it has to be (a litte bit under the navigation and at the same height as the content seperator line) - in internet explorer the box has no margin at all and not at the same height as the content seperator (#content) line

#2: in firefox the "veranstaltungen" box (#vbox) has a space between the .boxheader and the #vbox and i dont understand why because in internet explorer it isnt and i did nothing different compared to the box below (#wbox)

#3: in internet explorer the line under the menu item iPhone (its a border-bottom at #nav) is a little bit under the picture - but in firefox it does fit.

Can anybody help me please?

Panda
Panda's picture
Offline
Enthusiast
UK
Last seen: 11 years 30 weeks ago
UK
Timezone: GMT+1
Joined: 2010-04-25
Posts: 98
Points: 110

Don't use positioning and

Don't use positioning and floats on the same element.

Sidebar should be, or could be:

#sidebar{
  float: left;
  margin-top: -15px;
  width: 235px;
  }

No need for positioning on:

#vboxnav li{
  width: 208px;
  line-height: 2;
  list-style-type: none;
  border-bottom: 1px solid #ccc;
  left: -40px;
 }

But, the problem with this is, when you take off positioning here your items jump to the right?

This is because of vboxnav. Your code has styled vboxnav ul, which is the wrong order. The vboxnav id is inside the ul not the other way around. You can change it to:

#vboxnav  {
  width: 208px;
  list-style-type: none;
  padding: 0;
  margin: 0;
  }

pwn
pwn's picture
Offline
newbie
Vienna
Last seen: 11 years 29 weeks ago
Vienna
Timezone: GMT+2
Joined: 2010-06-04
Posts: 8
Points: 13

thank you very much for your

thank you very much for your help.

i could resolve the problem with the "open" vnav box.

I also fixed the #1 problem with this link: http://my.opera.com/dbloom/blog/2009/03/11/css-hack-for-ie8-standards-mode