16 replies [Last post]
Lorraine
Lorraine's picture
Offline
Elder
UK
Last seen: 13 years 1 week ago
UK
Timezone: GMT+1
Joined: 2005-01-04
Posts: 1001
Points: 0

For the second time recently my attachments do not appear to others.
For instance on this thread:
http://www.csscreator.com/css-forum/ftopic10686-15.html
The attachment at:
http://www.csscreator.com/css-forum/download.php?id=1406 is not visible/clickable.

What am I doing wrong?

thepineapplehead
thepineapplehead's picture
Offline
Guru
Last seen: 1 year 1 week ago
Timezone: GMT+1
Joined: 2004-06-30
Posts: 9668
Points: 801

A spot of bother with attachments.

Um, I can see it fine ?

Verschwindende wrote:
  • CSS doesn't make pies

Lorraine
Lorraine's picture
Offline
Elder
UK
Last seen: 13 years 1 week ago
UK
Timezone: GMT+1
Joined: 2005-01-04
Posts: 1001
Points: 0

A spot of bother with attachments.

Did you click the above URL or did you see it from the topic? Ciryaquen couldn't see an attachment in the topic and... I do believe... it was your goodself who could not see an attachment of mine in an earlier topic.
http://www.csscreator.com/css-forum/ftopic9294.html&highlight=

Chris..S
Chris..S's picture
Offline
Moderator
Last seen: 6 years 48 weeks ago
Timezone: GMT+1
Joined: 2005-02-22
Posts: 6078
Points: 173

A spot of bother with attachments.

I can see it in the topic.

larmyia
Offline
Elder
London
Last seen: 10 years 49 weeks ago
London
Timezone: GMT+1
Joined: 2005-01-25
Posts: 1060
Points: 0

A spot of bother with attachments.

me too

Lorraine
Lorraine's picture
Offline
Elder
UK
Last seen: 13 years 1 week ago
UK
Timezone: GMT+1
Joined: 2005-01-04
Posts: 1001
Points: 0

A spot of bother with attachments.

Curiouser and curiouser.
I've just logged out, turned off, cleared cache etc then viewed both the above topics as a guest. No attachments - what is going on here :?

thepineapplehead
thepineapplehead's picture
Offline
Guru
Last seen: 1 year 1 week ago
Timezone: GMT+1
Joined: 2004-06-30
Posts: 9668
Points: 801

A spot of bother with attachments.

As far as I know, with many forums, you can't view attachments unless you're logged in.

Could this be the case?

Verschwindende wrote:
  • CSS doesn't make pies

Lorraine
Lorraine's picture
Offline
Elder
UK
Last seen: 13 years 1 week ago
UK
Timezone: GMT+1
Joined: 2005-01-04
Posts: 1001
Points: 0

A spot of bother with attachments.

Does that mean you were not logged in when you said you couldn't see the attachment in:
http://www.csscreator.com/css-forum/ftopic9294.html&highlight=

thepineapplehead
thepineapplehead's picture
Offline
Guru
Last seen: 1 year 1 week ago
Timezone: GMT+1
Joined: 2004-06-30
Posts: 9668
Points: 801

A spot of bother with attachments.

Honestly? I can't remember Tongue

Verschwindende wrote:
  • CSS doesn't make pies

Lorraine
Lorraine's picture
Offline
Elder
UK
Last seen: 13 years 1 week ago
UK
Timezone: GMT+1
Joined: 2005-01-04
Posts: 1001
Points: 0

A spot of bother with attachments.

thepineapplehead wrote:
As far as I know, with many forums, you can't view attachments unless you're logged in.

Could this be the case?
Yep - did a bit of testing and it looks like you're right. Bit of a rum do for those who are looking around those fora before registering though - grumble, grumble. Crying

Hugo
Hugo's picture
Offline
Moderator
London
Last seen: 4 years 32 weeks ago
London
Joined: 2004-06-06
Posts: 15668
Points: 2806

A spot of bother with attachments.

It's the case that this is how thing work, I've noticed in the past that people have mentioned not being able to see attachments but then have logged in and found them appear, I agree that's it's a slightly rum do for those who may just be hanging around, I guess there is some good reason for it .

Hugo.

Before you make your first post it is vital that you READ THE POSTING GUIDELINES!
----------------------------------------------------------------
Please post ALL your code - both CSS & HTML - in [code] tags
Please validate and ensure you have included a full Doctype before posting.
Why validate? Read Me

Lorraine
Lorraine's picture
Offline
Elder
UK
Last seen: 13 years 1 week ago
UK
Timezone: GMT+1
Joined: 2005-01-04
Posts: 1001
Points: 0

A spot of bother with attachments.

I suppose this can easily happen when a member goes straight into a thread from a Topic Reply Notification email then replies and doesn't login until forced to by the submit button.

Anonymous
Anonymous's picture
Guru

A spot of bother with attachments.

I noticed that if I edit a message and try to attach a file during the edit it will not show.

Tony
Tony's picture
Offline
Moderator
Brisbane
Last seen: 3 weeks 2 days ago
Brisbane
Timezone: GMT+10
Joined: 2003-03-12
Posts: 5342
Points: 2963

A spot of bother with attachments.

That is the way attachments have worked since they were added.
I will have a closer look at making them visible to all, when I have time.

Has anyone noticed the text around the attachment form has disappeared.

Lorraine
Lorraine's picture
Offline
Elder
UK
Last seen: 13 years 1 week ago
UK
Timezone: GMT+1
Joined: 2005-01-04
Posts: 1001
Points: 0

A spot of bother with attachments.

Tony
Yes the text around the attachment form disappeared some time ago. I think you had done some sort of work on the whole site at the time and I *thought* it was a new feature. But, I see, you've already fixed it Laughing out loud

On the visibility of attachment links, the two people who pointed out they didn't see my attachments were forum members and I reckon they could have come into the threads from a Topic Reply Notification. Maybe that notification could suggest members should login before formulating their reply, in case there is an attachment or force a login before viewing the thread. As Hugo says, "it's a slightly rum do for those who may just be hanging around" (my emphasis), so changing the way attachments have always worked is not really important.

TY
Lorraine

Tony
Tony's picture
Offline
Moderator
Brisbane
Last seen: 3 weeks 2 days ago
Brisbane
Timezone: GMT+10
Joined: 2003-03-12
Posts: 5342
Points: 2963

A spot of bother with attachments.

Hi Lorraine,
I've got the text back Smile
I have also had a quick look in the attachment control panel and didn't notice anywhere to allow visitors to see attachments.
I will have another closer look after dinner.
There is an option to display attachments in the preview when posting.

roytheboy
roytheboy's picture
Offline
Guru
North Wales, UK
Last seen: 6 years 4 weeks ago
North Wales, UK
Timezone: GMT+1
Joined: 2004-09-18
Posts: 2233
Points: 41

A spot of bother with attachments.

Tony - at this rate you'll be asked to join the phpBB development team Wink

Life's a b*tch and then you die!