19 replies [Last post]
hen
Offline
Regular
Germany
Last seen: 12 years 12 hours ago
Germany
Joined: 2005-02-27
Posts: 47
Points: 0

Hi there,

as long as I'm using a static title for my website everything is okay with firefox:

hendrikwill.com/

but when I'm using a unique title for each page firefox is messing up the menu:

http://beta.hendrikwill.com

Any ideas how to fix this? I'd like to have a unique title for each page.

Update:

I built a new menu. Goto page 2 to see it...

thepineapplehead
thepineapplehead's picture
Offline
Guru
Last seen: 1 year 16 weeks ago
Timezone: GMT+1
Joined: 2004-06-30
Posts: 9668
Points: 801

New navigation, needs to be tested in several browsers

Sorry this doesn't help, it;s purely a usability point - but do you think you could make the link text a little darker? I find it very hard to read Laughing out loud

Verschwindende wrote:
  • CSS doesn't make pies

hen
Offline
Regular
Germany
Last seen: 12 years 12 hours ago
Germany
Joined: 2005-02-27
Posts: 47
Points: 0

New navigation, needs to be tested in several browsers

maybe the color makes it a little harder to read,
but look at the "contact" link...it disappears when the title switches.

thepineapplehead
thepineapplehead's picture
Offline
Guru
Last seen: 1 year 16 weeks ago
Timezone: GMT+1
Joined: 2004-06-30
Posts: 9668
Points: 801

New navigation, needs to be tested in several browsers

Sorry, I'm not seeing the problem you mentioned.

You've got yourself an awesome site though - just fix those colours!

Verschwindende wrote:
  • CSS doesn't make pies

hen
Offline
Regular
Germany
Last seen: 12 years 12 hours ago
Germany
Joined: 2005-02-27
Posts: 47
Points: 0

New navigation, needs to be tested in several browsers

thank you.

oh...I just saw that I use "Firefox 1.0 Preview Release (NF)" that might be the problem. Shock

what colors would you change? just the inactive link color to a slightly darker color?

hen
Offline
Regular
Germany
Last seen: 12 years 12 hours ago
Germany
Joined: 2005-02-27
Posts: 47
Points: 0

New navigation, needs to be tested in several browsers

I just installed the newest version of FF. Still the same problem! :roll:

The "Contact" link disappears when clicking on "Architecture" or "Events"...
http://beta.hendrikwill.com/

rmfred
rmfred's picture
Offline
Elder
Rock Springs, WY
Last seen: 1 year 8 weeks ago
Rock Springs, WY
Timezone: GMT-6
Joined: 2004-01-31
Posts: 1073
Points: 31

New navigation, needs to be tested in several browsers

I just tried it and the "Contact" link is still there when I click on either
"Architecture" or "Events"...

Sorry, but I can't seem to duplicate the problem you are seeing

thepineapplehead
thepineapplehead's picture
Offline
Guru
Last seen: 1 year 16 weeks ago
Timezone: GMT+1
Joined: 2004-06-30
Posts: 9668
Points: 801

New navigation, needs to be tested in several browsers

Ooooh, for a minute there I saw it! Laughing out loud

It messes up on events page. If you go to events, then back to news, you can see the problem:

I've no idea how to fix it though . . . sorry Laughing out loud

(Just a thought - do you use AdBlock?)

Verschwindende wrote:
  • CSS doesn't make pies

hen
Offline
Regular
Germany
Last seen: 12 years 12 hours ago
Germany
Joined: 2005-02-27
Posts: 47
Points: 0

New navigation, needs to be tested in several browsers

hmm, no I don't use AdBlock or anything similar...

Anyone else any ideas how to fix this? Crying

rmfred
rmfred's picture
Offline
Elder
Rock Springs, WY
Last seen: 1 year 8 weeks ago
Rock Springs, WY
Timezone: GMT-6
Joined: 2004-01-31
Posts: 1073
Points: 31

New navigation, needs to be tested in several browsers

Strange... done exactly what TPH said and it still works for me. Tried all the menus back and forth and still couldn't duplicate the problem. Even tried resizing the page, and clearing the cache... sorry

roytheboy
roytheboy's picture
Offline
Guru
North Wales, UK
Last seen: 6 years 19 weeks ago
North Wales, UK
Timezone: GMT+1
Joined: 2004-09-18
Posts: 2233
Points: 41

New navigation, needs to be tested in several browsers

It all works fine for me too (FF_Mac). On a well-calibrated Mac LCD monitor the nav links are way too difficult to see, and I've got normal eyesight! There's no where near enough contrast for what are the most important bits of text in the site.

Life's a b*tch and then you die!

hen
Offline
Regular
Germany
Last seen: 12 years 12 hours ago
Germany
Joined: 2005-02-27
Posts: 47
Points: 0

New navigation, needs to be tested in several browsers

This is really a mystery to me. I tried it on three different comps with the same version of Firefox. I was just able to duplicate the problem with one comp.

There aren't missing breaks or anything similar in the source which could arouse this.

Any ideas? Crying

hen
Offline
Regular
Germany
Last seen: 12 years 12 hours ago
Germany
Joined: 2005-02-27
Posts: 47
Points: 0

New navigation, needs to be tested in several browsers

okay, sorry for confusing you guys. I think a missing space and a needless space caused it. Shock

at least I know now that the color of the nav text was too bright.

thanks

hen
Offline
Regular
Germany
Last seen: 12 years 12 hours ago
Germany
Joined: 2005-02-27
Posts: 47
Points: 0

New navigation, needs to be tested in several browsers

I just cleared my browser cache and the problem appears again. Crying

Chris..S
Chris..S's picture
Offline
Moderator
Last seen: 7 years 11 weeks ago
Timezone: GMT+1
Joined: 2005-02-22
Posts: 6078
Points: 173

New navigation, needs to be tested in several browsers

From looking at your page I can't see what may be causing the problem. However, the styles for the menu seem overly complex.

(1) I am curious about the opera problem that prompted you to define the ul as display:table & table-layout:fixed and also the reason its position:absolute yet in the appropriate position to be flowed naturally.

I have a similar menu on one of my layout samples that works fine in Opera. That sample has a fixed width on the menu items, but it works fine with no width specified.

(2) Given you don't require a width for the li elements, you don't need to float them at all. You should be able to use display:inline and no display:block on the <a> elements (although you may still want display:inline-block)

Its my guess that if you can simplify the styling of the menu your problems are likely to go away - or at least they will be easier to pinpoint and eliminate.

hen
Offline
Regular
Germany
Last seen: 12 years 12 hours ago
Germany
Joined: 2005-02-27
Posts: 47
Points: 0

New navigation, needs to be tested in several browsers

thank you for your tips, Chris.

I tried to build a new navigation but I couldn't get it working.

I give up. Crying

hen
Offline
Regular
Germany
Last seen: 12 years 12 hours ago
Germany
Joined: 2005-02-27
Posts: 47
Points: 0

New navigation, needs to be tested in several browsers

okay, here comes a new version of the navigation. Works fine with IE6, FF and Opera 7.

example IE6:

Could someone have a try with Safari, MacIE and other browsers, please?

roytheboy
roytheboy's picture
Offline
Guru
North Wales, UK
Last seen: 6 years 19 weeks ago
North Wales, UK
Timezone: GMT+1
Joined: 2004-09-18
Posts: 2233
Points: 41

New navigation, needs to be tested in several browsers

Your beta site looks fine in FF_Mac, Safari and IE5.2_Mac, except for the later which shows a 1px white line at the base of the small spacers each side of the main buttons. But I wouldn't have noticed unless you had pointed it out before. It's fine, really it is - IE on the Mac is history Smile

Life's a b*tch and then you die!

thepineapplehead
thepineapplehead's picture
Offline
Guru
Last seen: 1 year 16 weeks ago
Timezone: GMT+1
Joined: 2004-06-30
Posts: 9668
Points: 801

New navigation, needs to be tested in several browsers

The beta site is looking much better.

The links are much easier to read, and it look sbetter all the nav links being the same width.

Good job.

Verschwindende wrote:
  • CSS doesn't make pies

hen
Offline
Regular
Germany
Last seen: 12 years 12 hours ago
Germany
Joined: 2005-02-27
Posts: 47
Points: 0

New navigation, needs to be tested in several browsers

Thanks again for your hints and testing my beta site. The new site is online now http://www.hendrikwill.com