2 replies [Last post]
helldiver
Offline
newbie
Amsterdam
Last seen: 16 years 1 week ago
Amsterdam
Joined: 2003-11-13
Posts: 3
Points: 0

I'm new here so my apologies is this is stupid question.

I cheerfully started to lay out my site with CSS and no tables. I have a basic layout now that works in Safari, Mozilla and IE5win. (http://www.webmeister.nl)

BUT it only works in IE5win if I apply one of the styles inline, rather than in the head of the document. With all styles in the head some of the page elements are not formatted properly and positioned in the wrong place.

The order in which the styles appear in the head seems to determine which page elements are affected. I'm completely at a loss. Safari and Mozilla render perfectly.

Does anyone have any idea what's going on?

moody
moody's picture
Offline
Regular
croatia
Last seen: 12 years 2 weeks ago
croatia
Timezone: GMT+1
Joined: 2003-09-21
Posts: 29
Points: 0

IE5win - layout works only with inline styles applied - ARRR

have you been working on this?

because after looking at it in ie 5.01, 5.5, 6.0 and firebird....other than minor pixel diferrences, your page looks the same.

am i missing something?

helldiver
Offline
newbie
Amsterdam
Last seen: 16 years 1 week ago
Amsterdam
Joined: 2003-11-13
Posts: 3
Points: 0

IE5win - layout works only with inline styles applied - ARRR

I put the page up so it worked in IE5. After your post I thought I'd better put it up broken so I started tinkering again. Now all the styles are in the head and suddenly it works!

I feel a bit silly now but I'm glad it works. I am still afraid to touch the code Smile IE5 is difficult with CSS. Anyway, thanks for having a look.