15 replies [Last post]
DJSdotcom
Offline
Enthusiast
Rochester, NY / Chicago, IL
Last seen: 16 years 25 weeks ago
Rochester, NY / Chicago, IL
Joined: 2003-03-23
Posts: 95
Points: 0

Hey everybody,

Now this problem is REALLY baffling me.

I'm currently working on a new site for my company, and for some reason, WHENEVER I open it up in IE 5.2 (MacOS X v10.2.4), IE crashes. It doesn't freeze, it doesn't load some of the content, I hit return after the URL and it crashes.

Just for the record, my code validates for XHTML 1.0 Transitional and CSS 2.0 by the W3C. Also, it works perfectly fine in ALL other browsers, Safari, Camino, IE6 WinXP, IE5 OS 9!!!... I just don't know why its doing this?

If anybody else is using IE for OS X, please check this URL out and tell me what happened:

http://www.realusability.net/test/

Thanks!

</twocents>

Tony
Tony's picture
Offline
Moderator
Brisbane
Last seen: 5 days 12 hours ago
Brisbane
Timezone: GMT+10
Joined: 2003-03-12
Posts: 5342
Points: 2963

HELP! IE5.x/MacOS X v10.2 crashes!!!

Hi DJSdotcom,
The site is looking good.
I'm not sure why it crashes and can't test it but I can offer some suggestions of things to try to help determine what the problem is.

Firstly you link to the same stylesheet twice once for scree media and once for print. Try removing one link and remove the media declaration from the other. Some browsers can't handle media types and its possible that this is causing a problem.

Then if that has no effect try changing the doctype declaration or removing it while you do some testing.

DJSdotcom
Offline
Enthusiast
Rochester, NY / Chicago, IL
Last seen: 16 years 25 weeks ago
Rochester, NY / Chicago, IL
Joined: 2003-03-23
Posts: 95
Points: 0

HELP! IE5.x/MacOS X v10.2 crashes!!!

Good point Tony.

I just removed the second <link> to the style sheet and took off the media attribute to the other, but to no avail.

I've been testing some things... if I type in the exact link to the images... they load. If I type in the link to "simple.css" (the style sheet for the page), it will load. But its the page that crashes it.

Also, I've noticed that it starts to load. Like it puts the title up on the window, says that its loading the pictures down at the status bar, but then before it gets past like three images, it crashes.

If anyone has IE 5.2, could they possibly try it out for me and tell me what happens?

http://www.realusability.net/test/

Thanks again.

</twocents>

nexia
nexia's picture
Offline
Regular
Last seen: 16 years 25 weeks ago
Timezone: GMT-5
Joined: 2003-03-22
Posts: 42
Points: 0

HELP! IE5.x/MacOS X v10.2 crashes!!!

hum... i have tested it with Camino, no trouble...

IE 5.2... bug is coming after loading the images/508.gif image... don't know why btw...

as suggested, cut this: media="all" ... it's not related to any compliance...

otherway, i don't see why my browser is crashing after accessing your page... it's sure because something is not compliant... did you checked your site with CSS/XHTML validators ?!

nexialism source of all knowledges

DJSdotcom
Offline
Enthusiast
Rochester, NY / Chicago, IL
Last seen: 16 years 25 weeks ago
Rochester, NY / Chicago, IL
Joined: 2003-03-23
Posts: 95
Points: 0

HELP! IE5.x/MacOS X v10.2 crashes!!!

Quote:
Just for the record, my code validates for XHTML 1.0 Transitional and CSS 2.0 by the W3C.

Yup, sure did. It even validates for Section 508 and Bobby Level A Accessibility validation too. Go figure.

As for the media attribute in the link tag, I am currently designing a different style sheet for printer usage, and just so I don't confuse myself, the media attribute set to "all" is there, so when I finally finish the print stylesheet, I can simply switch the regular one to media="screen", and the new printer one to media="print".

Also, I've removed the media attribute before and it has had no impact.

I have no idea what it could be... and apparently, no one else does either Wink

-Mike

</twocents>

Tony
Tony's picture
Offline
Moderator
Brisbane
Last seen: 5 days 12 hours ago
Brisbane
Timezone: GMT+10
Joined: 2003-03-12
Posts: 5342
Points: 2963

HELP! IE5.x/MacOS X v10.2 crashes!!!

Hi DJSdotcom,
Is the page still crashing :?:
I noticed you changed the link to bobby, was that link causing problems.

dJomp
dJomp's picture
Offline
Enthusiast
Last seen: 3 years 33 weeks ago
Joined: 2003-03-23
Posts: 422
Points: 0

HELP! IE5.x/MacOS X v10.2 crashes!!!

I think we need a plan of attack here!

Firstly try the page without the CSS style sheet. Then we can ascertain whether or not it's the HTML killing it or something in the CSS.

Then the really depressing slow bit... let's assume it's the CSS. Get the CSS file down to just the first rule, then load the page again. Add the next rule to the file. Reload. Repeat until it dies. Then you've got one CSS rule that kills it! Keep going (leaving out or rewriting each rule that kills it as you go) until you've got to the end of the CSS file.
Same kind of plan if it's the HTML. Keep adding bits of the page (divs, table rows etc) until it starts to die.

I know it's tedious and dull, but at least you'll find exactly what the source of the problem is! Had a completely unrelated problem with a completely different project a week ago and had to do something similar.

I've just read the posts again... do you have a MAC with IE5/OSX? If not then you need to get to one to do this!

Good luck, keep a full head of hair...

You know you're a geek when you try to shoo a fly away from the monitor with your cursor.

DJSdotcom
Offline
Enthusiast
Rochester, NY / Chicago, IL
Last seen: 16 years 25 weeks ago
Rochester, NY / Chicago, IL
Joined: 2003-03-23
Posts: 95
Points: 0

HELP! IE5.x/MacOS X v10.2 crashes!!!

Haha good point dJomp!

Yeah you guys are right, I'm going to remove the CSS style sheet from the page, and see what happens. I'm currently using my PowerBook for all the design and testing, and I've got pretty much every version of every Mac browser available for Mac OS X. UNFORTUNATELY that includes IE 5.x haha!

Also, Tony, changing the link on Bobby was a workaround for some stupid validation problem I was having. I really wanted the pages to validate for XHTML 1.0 STRICT, but for some reason, the Bobby link to the validation of the page didn't make it through the parser.

There were some crazy characters inside the URL that the XML parser choked out on, so I took the direct link out, and changed it just to the Bobby homepage. I figured if someone cared enough to check out the accessibility validation, they would manually input the URL Wink

I'm gonna start removing stuff, and see what happens.

Expect another post within like an hour from this one. I really appreciate everybody working on this one!

-Mike

</twocents>

DJSdotcom
Offline
Enthusiast
Rochester, NY / Chicago, IL
Last seen: 16 years 25 weeks ago
Rochester, NY / Chicago, IL
Joined: 2003-03-23
Posts: 95
Points: 0

HELP! IE5.x/MacOS X v10.2 crashes!!!

I took out the links to the style sheets... and it worked.

This means that the CSS is killing it. I also tested which CSS file killed it, and either of them did the trick.

Here's the simple.css code:

/* useweb (c)2003 */
A {
    text-decoration: none;
    font-weight: normal;
    border-bottom: 1px dotted green;
    color: black;
    background-color: transparent; }
    
A:hover {
    text-decoration: none;
    border-bottom: 1px dotted #F60;
    color: green;
    background-color: transparent; }
    
/* Header style redefinition */
H1, H2 { margin: 0px; padding: 0px; font-family: "Trebuchet MS", Verdana, sans-serif; }
H3, H4, H5 { padding: 0px; margin: 0px; color: black; background-color: inherit; font-family: Verdana, Arial, sans-serif; }

H1 { /* Big blue text at top of *most* pages */
    font-size: 26px;
    line-height: 1.3em;
    font-weight: normal;
    color: #369;
    background-color: inherit; }
    
H2 { /* Paragraph Headers */
    font-size: 18px;
    font-weight: bold;
    color: black;
    background-color: inherit; }
        
H3 { /* Regular size text */
    font-size: 13px;
    line-height: 1.4em;
    font-weight: normal; }
    
H4 { /* Larger text */
    font-size: 14px;
    line-height: 1.4em;
    font-weight: normal; }
    
H5 { /* Real small text */
    font-size: 11px;
    font-weight: bold; }
    
/* More specific header classes */
H2.green  { color: green; background-color: inherit; }
H2.orange { color: #F60; background-color: inherit; }
H2.blue, H4.blue, H5.blue { color: #369; background-color: inherit; }

/* Extraneous classes */
BODY { margin: 0px; }
EM { background-color: #FFA; color: inherit; text-decoration: none; font-style: normal; }
STRONG { font-weight: bold; font-style: italic; }
ACRONYM { border-bottom: 0px; color: gray; cursor: help; background-color: inherit; }
HR { height: 1px; border: 0px; background-color: #CCC; }

I figured maybe there's something obvious that we're missing that might crash it. Are there any IE 5.x CSS inconsitencies BESIDES the notorious box-model bug?

I kept this CSS really simple, and made the more complex style sheet transformations to "sophisto.css". I really don't know what's wrong with it... I mean it validates completely with only those stupid background-color warnings.

-Mike

</twocents>

Anonymous
Anonymous's picture
Guru

HELP! IE5.x/MacOS X v10.2 crashes!!!

I just tested it, sure enough it crashes. Ever considered the fact that IE 5 for Mac just sucks? Wink

DJSdotcom
Offline
Enthusiast
Rochester, NY / Chicago, IL
Last seen: 16 years 25 weeks ago
Rochester, NY / Chicago, IL
Joined: 2003-03-23
Posts: 95
Points: 0

HELP! IE5.x/MacOS X v10.2 crashes!!!

LOL Wink

Don't worry, before I started testing with it, I already knew that Mac IE sucks. Too bad that the majority of "non-designers" who use a Macintosh, use IE for browsing. If I don't figure out a fix for this, its going to alienate a large portion of the Mac community.

-Mike

</twocents>

Sven
Sven's picture
Offline
Enthusiast
Brisbane, Australia
Last seen: 12 years 14 weeks ago
Brisbane, Australia
Timezone: GMT+10
Joined: 2003-03-12
Posts: 166
Points: 0

HELP! IE5.x/MacOS X v10.2 crashes!!!

Apparently Setting vertical-align (to anything) and background:inherit on the same element will crash IE5/Mac. The crash does not occur if the style is set inline.

How about setting background to transparent in the cases that currently have inherit, and seeing if it makes any difference?

DJSdotcom
Offline
Enthusiast
Rochester, NY / Chicago, IL
Last seen: 16 years 25 weeks ago
Rochester, NY / Chicago, IL
Joined: 2003-03-23
Posts: 95
Points: 0

HELP! IE5.x/MacOS X v10.2 crashes!!!

WOW!

Where'd you see that tip?

Yeah, I'll definitely give it a shot... but not right now Smile It's 3:18am on the East Cost lol

-Mike

</twocents>

Anonymous
Anonymous's picture
Guru

more bugs

in addition to background: inherit, i found that color:inherit also caused the browser to bomb out - upone removal of this the browser works reliably.

with reference to the previous message, a search on google turned up this page with more details about the bugs:
http://www.l-c-n.com/IE5tests/misc/index.shtml

starchase
Offline
newbie
coastal georgia
Last seen: 16 years 18 weeks ago
coastal georgia
Timezone: GMT-4
Joined: 2003-05-12
Posts: 7
Points: 0

This Probably Isn't it . . . .

but maybe the comment inside the declaration tags is at fault.
H1 { /* Big blue text at top of *most* pages */
or the two extra "*" doing something? I thought I ran into a problem a while back putting a comment inside one of my declarations and when I removed it the problem went away. I know that the browser is supposed to ignore the comment but maybe there's a glitch anyway.

This probably isn't the problem in your specific case but I thought I'd throw it out there anyway.

John

DJSdotcom
Offline
Enthusiast
Rochester, NY / Chicago, IL
Last seen: 16 years 25 weeks ago
Rochester, NY / Chicago, IL
Joined: 2003-03-23
Posts: 95
Points: 0

HELP! IE5.x/MacOS X v10.2 crashes!!!

Thanks John.

Currently, development on that site has been put on hold because finals are this week Smile

Great point though, you're right about IE5 puking out on comments in odd places, I think I'll take that out.

-Mike

</twocents>