5 replies [Last post]
dada78
Offline
Regular
Last seen: 12 years 31 weeks ago
Joined: 2004-11-30
Posts: 16
Points: 0

Hi guys,

I am a Mac user and have problems figuring out, why the codes on the following sites, don't display correctly on Internet Explorer/ PC???

http://www.citykind.com/
http://www.carinafuller.com

What is missing in the sidebar are the links and the image carina.jpg + the amazon ad - basically nothing shows up in the sidebar, so I figure the culprit must be in the in the sidebar code. Also the top image (header.jpg) doesn't show either?

I would appreciate it if one of you can give it a look and give me a hint, becauce I really don't know what to change... Sad

Please note that the code doesn't validate because it is implemented in a blogger template, that is using specific tags to laod the dynamic content.

So you need to look at the attached code to determine what could be wrong.

I am looking forward to anybody's help!

Thanks guys!

briski
briski's picture
Offline
Elder
London
Last seen: 9 years 24 weeks ago
London
Timezone: GMT+1
Joined: 2004-02-16
Posts: 1066
Points: 0

To all PC users & experts:

The header is not showing up in IE but for me the side bar is working the same in both FF and IE6 and it looks fine. so not sure if you fixed that already.

To get the header to show add a space between the file and the no-repeat

ie.

background: url(http://www.citykind.com/img/header.jpg) no-repeat top;

That fixed it for me

roytheboy
roytheboy's picture
Offline
Guru
North Wales, UK
Last seen: 8 years 18 weeks ago
North Wales, UK
Timezone: GMT+1
Joined: 2004-09-18
Posts: 2233
Points: 41

To all PC users & experts:

Hi dada78,

I too work on a Mac but I have to use a PC to check everything I do on IE. It is an unfortunate fact of web-designer-life! If you have not already hacked your code for IE then you'll need to do so bit-by-bit. It's a pain I know! Evil

May I suggest that you start by getting hold of an old PC and then reading through this lot a few times > http://www.positioniseverything.net/explorer.html

Life's a b*tch and then you die!

briski
briski's picture
Offline
Elder
London
Last seen: 9 years 24 weeks ago
London
Timezone: GMT+1
Joined: 2004-02-16
Posts: 1066
Points: 0

To all PC users & experts:

Hmm the different sites different problems. Sorry I did not spot that before.

On the http://www.carinafuller.com the image reference of http://www.bionic-fnb.com/img/carina.jpg is not found which is why it does not appear.

As to the links they are there they have just floated down below the maincontent, I suspect that the side bar is a fraction too wide for IE for some reason.

briski
briski's picture
Offline
Elder
London
Last seen: 9 years 24 weeks ago
London
Timezone: GMT+1
Joined: 2004-02-16
Posts: 1066
Points: 0

To all PC users & experts:

Playing further I changed

.xml-button 
{
	float: right;
	margin-right: 130px;
}

to
.xml-button 
{
	display: inline
}

which seemed to do the trick.

dada78
Offline
Regular
Last seen: 12 years 31 weeks ago
Joined: 2004-11-30
Posts: 16
Points: 0

You guys are awesome!


Thank you for your responses!
Briski, I have followed your advice and hope that it works, since I don't have a PC to check the result. I only noticed on IE5.2 /Mac, that there is a bit of white space above the header that shouldn't be there. But it's not showing in Safari, Mozilla or Netscape. ?

Anyway thank you very much for this! I really appreciate it.

Also Roytheboy, the sitelink that you provided is a milestone! Will use it in the future! Thanx for that.

Oh-one more think before I forget it. I added a couple of banner ads to my site http://www.bionicmedia.us under the category "friends" and they again show fine on Mozilla, Netscape and Safari but IE is the problem child, which displays it horribly? Is there a fix for this? Well I will also look at the IE error site for this...

Dada