4 replies [Last post]
duckxtales
Offline
Regular
Last seen: 3 years 41 weeks ago
Timezone: GMT-5
Joined: 2007-05-15
Posts: 27
Points: 0

When you goto a page here:
http://www.expotv.com/Baby/c2

the page flickers at first and shows the page without CSS applied and then 1 second later it loads the CSS and the page is complete. What is the cause of this?

thanks

wolfcry911
wolfcry911's picture
Offline
Guru
MA, USA
Last seen: 5 years 36 weeks ago
MA, USA
Timezone: GMT-5
Joined: 2004-09-01
Posts: 3224
Points: 237

sounds like FOUC.

sounds like FOUC.

Hugo
Hugo's picture
Offline
Moderator
London
Last seen: 4 years 44 weeks ago
London
Joined: 2004-06-06
Posts: 15668
Points: 2806

Go wash your mouth

Go wash your mouth out!

Don't use to import your stylesheet it's an old and hacky approach, use the properrer link tag

Before you make your first post it is vital that you READ THE POSTING GUIDELINES!
----------------------------------------------------------------
Please post ALL your code - both CSS & HTML - in [code] tags
Please validate and ensure you have included a full Doctype before posting.
Why validate? Read Me

duckxtales
Offline
Regular
Last seen: 3 years 41 weeks ago
Timezone: GMT-5
Joined: 2007-05-15
Posts: 27
Points: 0

Awesome thanks!

Awesome thanks!

duckxtales
Offline
Regular
Last seen: 3 years 41 weeks ago
Timezone: GMT-5
Joined: 2007-05-15
Posts: 27
Points: 0

Actually it was not to do

Actually it was not to do with the

@import tag.

I think it was to do with the LINK tag being loaded below the SCRIPT tags. So far it seems like its gone.