3 replies [Last post]
Satan
Offline
Regular
Last seen: 18 years 12 weeks ago
Timezone: GMT-5
Joined: 2004-09-07
Posts: 14
Points: 0

Hi guys,

Is anyone having problems validating local pages after installing XP SP2 ? Or maybe it's from installing IIS 5.1 ?

I get this error: "I am unable to validate this document because its content type is text/plain..."

That never happened to me before and I can't tell if it's from XP SP2 or IIS because I installed them both at the same time. Just when I thought I had my system perfect (PHP working great, etc.) this happens.

Any ideas ?

Tony
Tony's picture
Offline
Moderator
Brisbane
Last seen: 1 week 5 days ago
Brisbane
Timezone: GMT+10
Joined: 2003-03-12
Posts: 5344
Points: 2965

W3C Validation Problems with XP SP2 ?

Hi Satan,
Check for mime types in your web server.
In most servers there is a way to add mime types either by a config file or an admin panel.

Hope that helps

Satan
Offline
Regular
Last seen: 18 years 12 weeks ago
Timezone: GMT-5
Joined: 2004-09-07
Posts: 14
Points: 0

W3C Validation Problems with XP SP2 ?

Hi,

It is an XP SP2 problem, lots (but not all for some reason) of people are experiencing the exact same thing.

IE6 uploads the document as text/plain.

There is a registry hack to fix it but it causes other problems.

Tony
Tony's picture
Offline
Moderator
Brisbane
Last seen: 1 week 5 days ago
Brisbane
Timezone: GMT+10
Joined: 2003-03-12
Posts: 5344
Points: 2965

W3C Validation Problems with XP SP2 ?

Hi Satan,
Another great reason to use FireFox Smile