12 replies [Last post]
mini
Offline
Regular
Last seen: 15 years 52 weeks ago
Joined: 2004-09-27
Posts: 24
Points: 0

Hello Having serious problems in IE
Anybody got any clues as to why???
I am kind of newish to CSS and this is a important test site.
PLEASE HELP!

http://kyteonline.com/5465_rutherfords_lettings

Please tell me what I am doing wrong...
Thank you. :?:

thepineapplehead
thepineapplehead's picture
Offline
Guru
Last seen: 26 weeks 5 days ago
Joined: 2004-06-30
Posts: 9668
Points: 801

Need help with layout in IE!!!!

I don't see what the problem is . . . it looks great!

Verschwindende wrote:
  • CSS doesn't make pies

mini
Offline
Regular
Last seen: 15 years 52 weeks ago
Joined: 2004-09-27
Posts: 24
Points: 0

Need help with layout in IE!!!!

Really!!!

I looked at it in Browsercam and the background was all over the place!!!

Really it works in IE?? XP???

What is going on here?

Are you shure?

tom_de_schlong
tom_de_schlong's picture
Offline
Enthusiast
UK
Last seen: 8 years 44 weeks ago
UK
Joined: 2004-06-13
Posts: 92
Points: 0

Need help with layout in IE!!!!

Hi there not sure what thepineapplehead was doing but when i looked at in IE6 on XP the LANDLORD SERVICES column is pushed below.

i would guess that this is simply because IE gets the box sizes wrong you should change the width or margin for IE this should fix it.

I would use the html>body hack to do this.

I can post more info on this if you need it.

Apart from that nice one a really well designed site

Want a free Ipod, live in the US or UK then please <a href="http//ipods.freepay.com/?r=21545802">check this out</a>. Plenty of people have already got one just search google for freeipods.com.

mini
Offline
Regular
Last seen: 15 years 52 weeks ago
Joined: 2004-09-27
Posts: 24
Points: 0

Need help with layout in IE!!!!

Hi Thank you.
I would lovve to know how to ficx that issue please do post it.

I looked yesterday at it on a PC XP and I also heva a problem with the properties page.
If you have any ideas as to why this is happening please let me know.

Thank you

tom_de_schlong
tom_de_schlong's picture
Offline
Enthusiast
UK
Last seen: 8 years 44 weeks ago
UK
Joined: 2004-06-13
Posts: 92
Points: 0

Need help with layout in IE!!!!

Ok so what you need to do to fix the problem i outlined in IE6 is add the following code to your layout.css file,

/* RIGHT SIDE*/


#rightsd {
clear:both;
width: 250px;
float: right;
margin: 10px auto 10px auto;
border-left: 1px solid #CCCCCC;
}
html>body #rightsd {
clear:none;
}

#righttext {
font-size: 11px;
text-align: left;
margin: 0px 20px 0px 20px;
}

This will fix the problem of the LANDLORD SERVICES panel slipping down.

I haven't looked at the other problem yet could you outline it more specifically and I will try to fix it.

Hope this helps

Tom

P.S I have checked the fix in all modern browsers on a PC (I don't have access to a Mac)

Want a free Ipod, live in the US or UK then please <a href="http//ipods.freepay.com/?r=21545802">check this out</a>. Plenty of people have already got one just search google for freeipods.com.

thepineapplehead
thepineapplehead's picture
Offline
Guru
Last seen: 26 weeks 5 days ago
Joined: 2004-06-30
Posts: 9668
Points: 801

Need help with layout in IE!!!!

Sorry, I mistakenly still had FF up. Looks great in FF though.

Verschwindende wrote:
  • CSS doesn't make pies

mini
Offline
Regular
Last seen: 15 years 52 weeks ago
Joined: 2004-09-27
Posts: 24
Points: 0

Need help with layout in IE!!!!

Cool thanks !
so nice of you.

I will give it a go in a couple of minutes.

Problem with the renting pages. The logo at the top moves to the righ and looses it's 10px border. Maybe because of the thumb divs (area with the property picts) expands the page?

I really don't know but I have a feeling it is to do with the IE issue of double margins?

What is the clear:both; property?

thanks again

ZB-Rob
ZB-Rob's picture
Offline
Regular
Netherlands
Last seen: 16 years 18 weeks ago
Netherlands
Timezone: GMT+2
Joined: 2004-05-16
Posts: 32
Points: 0

Need help with layout in IE!!!!

I do have one complaint regarding the link area in the navigation. The links have no area, just text. Try increasing the padding somewhat. It may fark up your intended idea, but Fitt's Law counts IMO.

Zooibaai.nl

mini
Offline
Regular
Last seen: 15 years 52 weeks ago
Joined: 2004-09-27
Posts: 24
Points: 0

Need help with layout in IE!!!!

Good morning!

I have done some changes to the css file as advised.
Can you please let me know if the index and the properties pages work now in IE XP

Rob: have not changed the text links yet, will look into that.

Again thank you all.

mini
Offline
Regular
Last seen: 15 years 52 weeks ago
Joined: 2004-09-27
Posts: 24
Points: 0

Need help with layout in IE!!!!

Ok getting a little pissed with this now!

Top Logo picture border!

Before it did not work in IE XP now that I have changed the css file to inclued a 10px marchin on the right side it does not work in Safri and Moz...

Any ideas as to how I can make it centered in the middle with a 10px border around it?

Thank you

mini
Offline
Regular
Last seen: 15 years 52 weeks ago
Joined: 2004-09-27
Posts: 24
Points: 0

Need help with layout in IE!!!!

Hello
Fixed the problem

Got ride of the margins and it sits well in the middle now.

Good day to you all.

Thanks for all your help.

mini
Offline
Regular
Last seen: 15 years 52 weeks ago
Joined: 2004-09-27
Posts: 24
Points: 0

Need help with layout in IE!!!!

Well I thought I had fixed it but I have not!
Browsercam looked fantastic but when I checked on IE XP latest version to my surprise the borders around the top logo were not equal... and the properties page was again crazy!
Please give me some advice The site has gone live and I don't want the client to see it until this is fixed any ideas??? or solutions
Thanks

New link:
http://www.rutherfordslettings.co.uk