12 replies [Last post]
cmahan
Offline
newbie
Last seen: 17 years 11 weeks ago
Joined: 2004-09-20
Posts: 7
Points: 0

I have started to convert an old web site from graphic based nav to nav generated by style sheets. Code validates and works fine in safari, IE both mac and windows but I can't get it to work in Netscape. If I paste the style code directly onto the page it works. I've tried moving style sheet link to different places in the head tag but that hasn't helped.

Anyone have any ideas on what is going on here? You can see what I mean at http//www.americanhiking.org/join/

Thanks for any suggestions or ideas.

Connie
[/url][/i]

rmcivo1
Offline
Enthusiast
Shropshire | Shrewsbury
Last seen: 10 years 38 weeks ago
Shropshire | Shrewsbury
Joined: 2003-12-05
Posts: 115
Points: 0

Netscape 7 not displaying styles

I saved the webpage on my machine, opened it up and it worked... I think the problem is of the location of the stylesheet I would move it in the same directory as the html document. And modify the importing of the sytle:

<link href="style.css" rel="stylesheet" type="text/css">

I dont know where the actual problem is, but I think that would sort it?
Regards
Rees

The Cyber World

cmahan
Offline
newbie
Last seen: 17 years 11 weeks ago
Joined: 2004-09-20
Posts: 7
Points: 0

Netscape 7 not displaying styles

Well, those were good suggestions (though none of them worked) and after playing around with it some more, it appears to be the doc type that is the problem

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http//www.w3.org/TR/1999/REC-html401-19991224/loose.dtd">

Anyone see any issues with this? I'm sure I cut and pasted it from good source, but who knows.

The styles are working still in IE and Safari, but they are too big without the governence of the doc type. Gotta find a happy medium.

A page without the doc type is here http//www.americanhiking.org/events/index2.html

Thanks for any other thoughts,

Connie

cmahan
Offline
newbie
Last seen: 17 years 11 weeks ago
Joined: 2004-09-20
Posts: 7
Points: 0

Netscape 7 not displaying styles

I've narrowed it down to the second piece of the doc type


<"http//www.w3.org/TR/1999/REC-html401-19991224/loose.dtd">

If that comes out, it displays ok in netscape but the text styles are bigger than if that code is in there in both IE and Safari (and netscape too for that matter). So I guess I could tweak the style sheet so they size properly BUT it seems like there should be something that will work with Netscape.

Anyone got a doc type that is working well for them?

Thanks,

Conie

rmcivo1
Offline
Enthusiast
Shropshire | Shrewsbury
Last seen: 10 years 38 weeks ago
Shropshire | Shrewsbury
Joined: 2003-12-05
Posts: 115
Points: 0

Netscape 7 not displaying styles

I use: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

It works brill for me Laughing out loud but you have to write in XHTML. I recommed people to start writing in this Mark-up language now becuase It is taking over HTML.

Regards

The Cyber World

cmahan
Offline
newbie
Last seen: 17 years 11 weeks ago
Joined: 2004-09-20
Posts: 7
Points: 0

Netscape 7 not displaying styles

Hi Rees,

That worked -- thanks! It's a better doc type for me anyway, as the pages conform to xhtml rules more that html. Not sure why I was using the other doc type, actually, now that I think about it. It's still oddly large in netscape, but certainly acceptable and I REALLY appreciate your taking a look at this and offering a solution!

Connie

rmcivo1
Offline
Enthusiast
Shropshire | Shrewsbury
Last seen: 10 years 38 weeks ago
Shropshire | Shrewsbury
Joined: 2003-12-05
Posts: 115
Points: 0

Netscape 7 not displaying styles

to be honest connie, I didnt know if that would work... I am glad it has though

Laughing out loud

The Cyber World

roytheboy
roytheboy's picture
Offline
Guru
North Wales, UK
Last seen: 8 years 19 weeks ago
North Wales, UK
Timezone: GMT+1
Joined: 2004-09-18
Posts: 2233
Points: 41

Netscape 7 not displaying styles

cmahan wrote:
It's still oddly large in netscape

Connie,
I'm no expert but the font size problems you are experiencing may be down to the fact that you are working within tables. This leads me onto another point of discussion which I was going to post when I get time, but for now, try using the 'table' element in your selector thus : table h1 { ... } and you should find that the text will conform with your attributes, as opposed to taking the default browser setting.

Life's a b*tch and then you die!

cmahan
Offline
newbie
Last seen: 17 years 11 weeks ago
Joined: 2004-09-20
Posts: 7
Points: 0

Netscape 7 not displaying styles

Thanks, I'll give that a try.

Very much appreicate it.

Connie

cmahan
Offline
newbie
Last seen: 17 years 11 weeks ago
Joined: 2004-09-20
Posts: 7
Points: 0

Netscape 7 not displaying styles

Actually, the different doc type didn't work. I'm still getting no styles on Netscape pages. Maybe I didn't check it online before, not sure. It always displays correctly when viewed locally and as I said, when I paste the style sheet code into the header, it works. It's like it's not seeing the style link at all.

So, still looking for a solution here.

Thanks,

Connie

Tony
Tony's picture
Offline
Moderator
Brisbane
Last seen: 1 day 18 hours ago
Brisbane
Timezone: GMT+10
Joined: 2003-03-12
Posts: 5344
Points: 2965

Netscape 7 not displaying styles

Hi cmahan,
Try validating the site.
The html comes up with many errors, one is that the comments have -- characters in them which are not allowed.
CSS validation also points to the same problem.

http://validator.w3.org/check?verbose=1&uri=http%3A//www.americanhiking.org/join/

http://jigsaw.w3.org/css-validator/validator?profile=css2&warning=2&uri=http%3A//www.americanhiking.org/join/

Fix up the errors and the CSS is more likely to display correctly.

Hope that helps

cmahan
Offline
newbie
Last seen: 17 years 11 weeks ago
Joined: 2004-09-20
Posts: 7
Points: 0

Netscape 7 not displaying styles

Yeah, I'm sure there are html errors in there but I did validate the style sheet and it was fine. Netscape displays styles fine for other pages on the site that have had the secondary nav converted to css, so maybe there is something there that is knocking it out of whack.

I'll keep fiddling with it and I appreciate all these suggestions!

Connie

JimD
Offline
newbie
Washington
Last seen: 17 years 10 weeks ago
Washington
Joined: 2004-09-24
Posts: 1
Points: 0

Netscape 7 not displaying styles

I have a website at http://faculty.washington.edu/crowther/KidsZone/

that (I am told) looks really bad using Netscape - but in IE, I think looks fine and loads quickly. From the only PC I have with Netscape, I tried to take a glance at the website in Netscape 7.1 and wouldn't even open.

Do you have any quick hints on what is wrong?

It had crossed my mind that the DOCTYPE parameters might need changing.

I also have suspected the .css files are not being handled correctly - or might be invalid. If so, what is the fix - use a different font?