2 replies [Last post]
Taff
Offline
newbie
Last seen: 14 years 9 weeks ago
Joined: 2005-04-22
Posts: 5
Points: 0

Hi,
I've updated the secondary template for our CMS at http://www.texaspete.us/cookie.html and the menu works pretty well. When I mouse over an image I get a dropdown. This works in IE7 and Firefox as I hoped it would (just needs a few pixels pushing).

The homepage (http://www.texaspete.us)was built using a table because of the amount of elements involved and the fact we would never know which would be the longest. I'm using exactly the same menu structure (and the same css) and it works in Firefox.

Unfortunately IE is not displaying any dropdowns at all, and I am at a loss as to why. I tried stripping out all the other HTML apart from the menu...and it still won't appear.

If anyone can tell me why, I would be so grateful, and providing you have a paypal account, I'd be more than happy to buy you a beer or 2 or 3.

I've been outsourced to complete this project for a company in the US who are short staffed and they need to present it on Friday!!

I am at a loss and you guys are the ace up my sleeve Smile

Cheers,
Taff

Tyssen
Tyssen's picture
Offline
Moderator
Brisbane
Last seen: 7 years 43 weeks ago
Brisbane
Timezone: GMT+10
Joined: 2004-05-01
Posts: 8201
Points: 1386

The page that's not working

The page that's not working has a bunch of meta tags above the doctype. Anything before the doctype puts IE into quirks mode.

How to get help
Post a link. If you can't post a link, jsFiddle it.
My blog | My older articles | CSS Reference

Taff
Offline
newbie
Last seen: 14 years 9 weeks ago
Joined: 2005-04-22
Posts: 5
Points: 0

Tyssen wrote:The page that's

Tyssen wrote:
The page that's not working has a bunch of meta tags above the doctype. Anything before the doctype puts IE into quirks mode.

Wow!
I don't know how many times I had looked at the source code and missed that. I would appreciate it if you could PM me your paypal account for a few beers. You have saved me lots and lots of work!

Taff