12 replies [Last post]
Error404
Offline
Regular
Last seen: 14 years 16 weeks ago
Joined: 2007-03-24
Posts: 11
Points: 0

Hi. Suddenly my Internet Explorer 6 started not showing up CSS styles locally at all. All is well when I am looking at any online site, but if I am trying to view some site from my hard drive to check how it looks then page shows like it just doesn't recognize CSS styles at all, it's without any styles. This is very strange and never happened to me before. I even tried "Work offline" option but that didn't serve also. Anyone with good answer?

Thanks,
Nikola

Error404
Offline
Regular
Last seen: 14 years 16 weeks ago
Joined: 2007-03-24
Posts: 11
Points: 0

I want to add that I've

I want to add that I've checked links if CSS is correctly included, and I've been also opening same pages offline in Firefox and everything is looking good... just in IE it is the case that CSS is not shown for any offline content. Please help, I really need this to work and I have to check every site I create in IE6 of course so it's important.

Hugo
Hugo's picture
Offline
Moderator
London
Last seen: 7 years 30 weeks ago
London
Joined: 2004-06-06
Posts: 15668
Points: 2806

You will have to provide far

You will have to provide far more depth than you have unless you want to receive generalised speculations - which most of us are never too interested in doing!.

Show us the files you have.

Before you make your first post it is vital that you READ THE POSTING GUIDELINES!
----------------------------------------------------------------
Please post ALL your code - both CSS & HTML - in [code] tags
Please validate and ensure you have included a full Doctype before posting.
Why validate? Read Me

Error404
Offline
Regular
Last seen: 14 years 16 weeks ago
Joined: 2007-03-24
Posts: 11
Points: 0

Ok. Here is the example of

Ok. Here is the example of one page not showing CSS offline, if I update it to any server and open again but online it shows correctly, so I am 100% sure this has nothing to do with files but with IE just not showing CSS while page offline for some reason, but OK I am showing you the code just so that you know I am right about it.

As you can see it's normal code, CSS is included in standard way... there are no any errors, I checked and validated... so then I know and I am totally sure this has to do something with IE settings and nothing with my files, I just don't know what is needed to be changed and that is the answer I am looking for...

Thanks

So HTML:

Creditstart.com - the easiest solution for all your credit needs

Welcome
Clients about us:

Welcome to Creditstart site...
What we can offer you for
FREE is analysis of your
personal situation before
shopping yoar loan, your
chances of getting a loan, up
to date information, website
links and other useful
resources to help you improve
your credit. Take a look..

 Thank you for your help in purchasing
my home. After a previous bankrupticy
and a foreclosure, I did not believe I
could ever buy a house again. Now I
own the house that I had being paying
rent in for years.

L. R. Florida

and CSS

@charset "utf-8"; #container { width: 822px; margin-right: auto; margin-left: auto; background-color: #36728C; position: relative; } #header { background-image: url(images/headerbckg.jpg); height: 329px; width: 822px; padding-bottom: 9px; background-color: #36728c; background-repeat: no-repeat; display: block; background-position: right top; } body { margin: 0px; font-family: Arial, Helvetica, sans-serif; } #maintitle { background-image: url(images/maintitle.jpg); background-repeat: repeat-x; height: 24px; width: 822px; background-color: #3E8AAA; background-position: right; } #alltext { background-image: url(images/textbck.jpg); background-repeat: repeat-y; width: 732px; background-position: right; background-color: #36728C; padding-left: 50px; padding-right: 40px; } #footer { background-image: url(images/footer.jpg); background-repeat: repeat-x; height: 34px; width: 822px; background-position: right; margin-top: 5px; } #search { font-size: 11px; color: #FFFFFF; width: 245px; position: absolute; left: 52px; top: 130px; } #search img { margin-top: 2px; border-top-width: 0px; border-right-width: 0px; border-bottom-width: 0px; border-left-width: 0px; } #search input { width: 138px; } .title1 { font-size: 18px; color: #f96f24; position: absolute; left: 395px; top: 164px; font-weight: bold; } .title2 { font-size: 18px; color: #f96f24; position: absolute; left: 574px; top: 170px; font-weight: bold; width: 170px; } .sitantext { font-size: 11px; color: #35718A; width: 150px; position: absolute; left: 396px; top: 187px; line-height: 13px; } .sitantext2 { font-size: 11px; color: #35718A; width: 207px; position: absolute; left: 569px; top: 197px; line-height: 13px; } .potpis { width: 85px; position: absolute; color: #1d6382; left: 694px; top: 293px; font-size: 14px; height: 35px; }

Error404
Offline
Regular
Last seen: 14 years 16 weeks ago
Joined: 2007-03-24
Posts: 11
Points: 0

And you can see page online

And you can see page online here:
http://www.kucicezapse.com/credit/index.html

Try to download it to your hard drive, open it in IE and it will surely look good in IE on your computer, but my settings in IE are wrong and I don't know what happened. I tried ever reinstalling and it didn't work. So this is kind of technical questions about what is needed to change in IE to make it show CSS while you are viewing pages offline. I again say it works great with online pages.

Ed Seedhouse
Ed Seedhouse's picture
Offline
Guru
Victoria British Columbia
Last seen: 1 year 24 weeks ago
Victoria British Columbia
Timezone: GMT-8
Joined: 2005-12-14
Posts: 3570
Points: 675

The html on that page is so

The html on that page is so messed up that anything can happen in a browser. There is no CSS standard for invalid html!!

Get the html valid first, and then see if the problem is still there.

Ed Seedhouse

Posting Guidelines

Watch out! I am carrying irony, sarcasm and satire, and know how to use them.

Error404
Offline
Regular
Last seen: 14 years 16 weeks ago
Joined: 2007-03-24
Posts: 11
Points: 0

I don't see how you see it

I'm not sure how you see this code messed up or invalid, this is totally valid code. It's very clear HTML to fallow, and it's already valid by XHTML standards, I checked, not one error. Thanks anyway... And I am saying again this has nothing to do with this page, it happens to any I view offline, even if I created it or anyone else...

Ed Seedhouse
Ed Seedhouse's picture
Offline
Guru
Victoria British Columbia
Last seen: 1 year 24 weeks ago
Victoria British Columbia
Timezone: GMT-8
Joined: 2005-12-14
Posts: 3570
Points: 675

The page you gave the link

The page you gave the link to, http://www.kucicezapse.com/credit/index.html has 23 xhtml validation errors, as you can see here: http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fwww.kucicezapse.com%2Fcredit%2Findex.html.

The W3C validator is the standard, and if it says you have errors then you have them, period.

Nor is it "good" code or "clear" code on visual inspection. It has a bad case of divitis and is not very semantic. Massive use of the BR element is always an indication of bad coding pracitces. Sorry, but if that's your page, its a mess.

Ed Seedhouse

Posting Guidelines

Watch out! I am carrying irony, sarcasm and satire, and know how to use them.

Error404
Offline
Regular
Last seen: 14 years 16 weeks ago
Joined: 2007-03-24
Posts: 11
Points: 0

Ok then. So if my page is

Ok then. So if my page is not valid then no one here will not give me answer to totally different question that has nothing to do with that one page but WITH IE SETTINGS, and I said that millions time by now and I explained how I came to conclusion. Damn... :/

Triumph (not verified)
Anonymous's picture
Guru

I'll put you in for a full

I'll put you in for a full refund.

Ed Seedhouse
Ed Seedhouse's picture
Offline
Guru
Victoria British Columbia
Last seen: 1 year 24 weeks ago
Victoria British Columbia
Timezone: GMT-8
Joined: 2005-12-14
Posts: 3570
Points: 675

If you already know the

If you already know the answer, why are you coming here for help? We are not the "IE Setting Help" forum we are the "CSS Creator" forum.

However until you can show me an example of IE not working in this particular way when fed with valid code I can't see any reason to conclude that it is IE's fault. I generally prefer that any conclusions I draw be based on evidence, you know.

IE has many faults but I haven't come across that one before, and if it is IE's fault this is not the right forum to ask for help on, surely.

Ed Seedhouse

Posting Guidelines

Watch out! I am carrying irony, sarcasm and satire, and know how to use them.

Phreestyle
Phreestyle's picture
Offline
Enthusiast
Australia
Last seen: 6 years 29 weeks ago
Australia
Timezone: GMT+8
Joined: 2007-05-12
Posts: 235
Points: 6

@OP It may help us to help

@OP

It may help us to help you if you could answer these questions:

You say 'suddenly stopped working in IE6'. Does that mean it was working and now doesn't? If so what changed?

Have you used another browser? Does the problem reoccur?

Are you using a scripting language? PHP ASP? Is your server set up correctly to allow you to test offline?

Life's a journey. Enjoy the trip.

Error404
Offline
Regular
Last seen: 14 years 16 weeks ago
Joined: 2007-03-24
Posts: 11
Points: 0

Ok, thank you all. I guess

Ok, thank you all. I guess this qustion has to go to some IE forum, I was just hoping getting answers here since it has to do with displaying CSS in IE.
Phreestyle, thanks for questions, well yes what I am trying to say is that suddenly any site that I open in IE offline (and I mean ANY that's why I was asking you all why are we talking about any code validation for one site that is just example) stopped displaying CSS. So everything is looking great online but any site I view offline, being code valid or not, doesn't matter, it just doesn't display CSS code for page. Page then looks like if you would disable CSS manually for it. So I hope you're getting my point.
Same site if I view if offline in Firefox (which I really love much more hehe) looks really good and CSS is displayed. Also with Opera, so the problem is just in IE NOT DISPLAYING CSS CONTENT FOR ANY OFFLINE PAGE, and that's it.
Also it doesn't have to do nothing with any scripting langueage, as I said it's acting same for ANY page, not only the one I provided, and I provided example page just because someone here asked, I really shouldn't do that because everyone just started talking about the validation of that page that has nothing to do with anything, and I guess I explained that now why.
So if anyone have any answer to my question thanks, just let's not talk about something I really haven't asked. I don't wanna sound rude or ungrateful, and thank you all really, but just lets please stick to the topic if anyone has to say anything about it. If not, thanks anyway for trying to help.