2 replies [Last post]
smk2007
smk2007's picture
Offline
Enthusiast
Last seen: 9 years 6 weeks ago
Timezone: GMT-8
Joined: 2007-01-04
Posts: 135
Points: 7

Hello there. I'm not sure if I can get help on this one but thought I'd give it a try.

I'm having this strange issue in IE6 rendering that I don't get in FF or IE7. I've tried various hack but no such luck. I've attached the proper rendering, and the bad rendering sample screen shots. As you can see, in IE6 the right column collapses inward whereas in the other browsers it renders properly? Please, any advise will be so appreciated.

Here is my CSS code:

}
#leftColumn {
width:180px;
float:left;
position:relative;
margin:0;
padding: 0 0 10px 0;
color:#fff;
background: url(../images/bottom-left.gif) bottom left no-repeat;
overflow:hidden
}
#leftInner {
padding:8px 12px 6px 8px;
margin:0 0 8px 0;
background: url(../images/top-left.gif) top left no-repeat;
}
#rightColumn {
width:180px;
float:right;
position:relative;
color:#fff;
margin:0;
padding: 0 0 10px 0;
background: url(../images/bottom-right.gif) bottom right no-repeat;
overflow:hidden
}
#rightInner {
padding:8px 8px 6px 12px;
margin:0 0 8px 0;
background: url(../images/top-right.gif) top right no-repeat;
}
#mainContent {
background: #fff;
width:55.7%;
margin:5px 8px;
float:left;
position:relative;
}
.inner { padding:15px }

And here is my xhtml/php code snipplet, which is in a CMS:

<?php if(mosCountModules( 'right' )>0 && mosCountModules( 'left' )>0){ ?>

<?php mosLoadModules ( 'left', -2 ); ?>
<?php mosMainBody(); ?>
<?php mosLoadModules ( 'right', -2 ); ?>

thepineapplehead
thepineapplehead's picture
Offline
Guru
Last seen: 1 week 5 days ago
Joined: 2004-06-30
Posts: 9668
Points: 801

smk2007 wrote:And here is my

smk2007 wrote:
And here is my xhtml/php code snipplet, which is in a CMS:

We don't ask for snippets and we do ask for server output Wink

Verschwindende wrote:
  • CSS doesn't make pies

smk2007
smk2007's picture
Offline
Enthusiast
Last seen: 9 years 6 weeks ago
Timezone: GMT-8
Joined: 2007-01-04
Posts: 135
Points: 7

thanks...

I solved my problem by removing the floats. thanks anyway...