14 replies [Last post]
Hogan
Offline
newbie
Last seen: 14 years 3 weeks ago
Joined: 2007-11-11
Posts: 10
Points: 0

Hi,

My page layout is fine in IE6 (on Windows XP) but its all over the place in IE7 (on Windows Vista).

I've attached my CSS file. What I want is for the panels to remain a fixed size on all browsers.

I've attached screenshoots of both. IE6 is the way it should look.

Does anyone have any ideas as to why things go badly wrong in IE7?

Thanks.

Regards, Hogan.

thepineapplehead
thepineapplehead's picture
Offline
Guru
Last seen: 4 days 20 hours ago
Joined: 2004-06-30
Posts: 9679
Points: 815

I don't see any

I don't see any attachments.

However, don't bother. Post ALL the HTML and CSS inbetween code tags, or better yet, give us a link to the page.

Verschwindende wrote:
  • CSS doesn't make pies

Hogan
Offline
newbie
Last seen: 14 years 3 weeks ago
Joined: 2007-11-11
Posts: 10
Points: 0

Sorry, forgot the

Sorry, forgot the attachments. IE7.jpg in the next comment as I can't seem to get it to take three attachments.

AttachmentSize
gaaradio.txt 21.51 KB
IE6.jpg 593.66 KB
IE7.jpg 520.62 KB
Hogan
Offline
newbie
Last seen: 14 years 3 weeks ago
Joined: 2007-11-11
Posts: 10
Points: 0

thepineapplehead wrote:I

thepineapplehead wrote:
I don't see any attachments.

However, don't bother. Post ALL the HTML and CSS inbetween code tags, or better yet, give us a link to the page.

Thanks.

You can get to the IE7 page with the following link:

http://81.86.244.196/gaaradio/home.jsp

thepineapplehead
thepineapplehead's picture
Offline
Guru
Last seen: 4 days 20 hours ago
Joined: 2004-06-30
Posts: 9679
Points: 815

They're all over the place

They're all over the place in Firefox, too. Although the 645 validation errors may have something to do with that Wink

Verschwindende wrote:
  • CSS doesn't make pies

Hogan
Offline
newbie
Last seen: 14 years 3 weeks ago
Joined: 2007-11-11
Posts: 10
Points: 0

What are 645 Validation Errors?

What are those 645 errors? How do I go about correcting them?

Why would they appear in IE7 and not in IE6?

Thanks.

Hogan
Offline
newbie
Last seen: 14 years 3 weeks ago
Joined: 2007-11-11
Posts: 10
Points: 0

Oops, I just realised that

Oops, I just realised that 645 is the number of errors! :blushing:

I see some of those errors relate to embedded scriptlets. Will those disappear once I sort of all of the close tag errors etc (i.e. all the XHTML errors)?

I meant to ask is the CSS looked ok for what I want to do, i.e. making my panels a fixed size?

Thanks.

thepineapplehead
thepineapplehead's picture
Offline
Guru
Last seen: 4 days 20 hours ago
Joined: 2004-06-30
Posts: 9679
Points: 815

We'll have a look at that

We'll have a look at that once you get the HTML valid. Replacing all & with & and closing the tags properly will reduce that number to about 10 Wink

Verschwindende wrote:
  • CSS doesn't make pies

Hogan
Offline
newbie
Last seen: 14 years 3 weeks ago
Joined: 2007-11-11
Posts: 10
Points: 0

Javascript & XHTML

Hi,

I changed my Javascript to replace the & with &. Now it passes the validation but the Javascript doesn't work? Do you know how to get around that one?

I guess what I'm asking is how to I escape two consecuative ampersands (i.e. the and operator in Javascript)?

Thanks.

Hogan.

Hogan
Offline
newbie
Last seen: 14 years 3 weeks ago
Joined: 2007-11-11
Posts: 10
Points: 0

Got It!

I found the solution to the javascript problem on the web. I've now got the page to pass the validation so now I just need to copy the changes across to the Vista machine. I'll do that when I get home this evening, and let you know how the page displays.

thepineapplehead
thepineapplehead's picture
Offline
Guru
Last seen: 4 days 20 hours ago
Joined: 2004-06-30
Posts: 9679
Points: 815

Excellent, let us know when

Excellent, let us know when it's all ready to have another look at, we'll see if it's still broken and if we can fix it Laughing out loud

Verschwindende wrote:
  • CSS doesn't make pies

Hogan
Offline
newbie
Last seen: 14 years 3 weeks ago
Joined: 2007-11-11
Posts: 10
Points: 0

Hi, I've now got the

Hi,

I've now got the updated page running on the Vista box and it is validating ok.

However the appearance is still as it was (i.e. all over the place Smile)

I was wondering if you could take a look at the css to see what's wrong with it?

Thanks.

thepineapplehead
thepineapplehead's picture
Offline
Guru
Last seen: 4 days 20 hours ago
Joined: 2004-06-30
Posts: 9679
Points: 815

Have you got the latest

Have you got the latest version online anywhere?

Verschwindende wrote:
  • CSS doesn't make pies

Hogan
Offline
newbie
Last seen: 14 years 3 weeks ago
Joined: 2007-11-11
Posts: 10
Points: 0

Sure, its at the same

Sure, its at the same address: http://81.86.244.196/gaaradio/home.jsp

Hogan
Offline
newbie
Last seen: 14 years 3 weeks ago
Joined: 2007-11-11
Posts: 10
Points: 0

Hi, I need to take the

Hi, I need to take the machine down tonight. I'm not sure if you've had a chace to look at the code yet? I'll bring it back up in the morning.

Thanks.