4 replies [Last post]
chikoppi
Offline
Enthusiast
Last seen: 11 years 35 weeks ago
Timezone: GMT-6
Joined: 2006-06-25
Posts: 85
Points: 2

Here's an IE display bug I can't quite make sense of.

LIVE HTML: http://www.rightmindinc.com/ubnew/index.html
IE7 SCREEN: http://browsershots.org/screenshots/ebf23d92e9d2b563e919c0d9674ca816/
IE6 SCREEN: http://browsershots.org/screenshots/f08c67264581ab87006b62948a8e0fef/

Above the left-side navigation an image should appear. The image appears in IE7 (see the screen capture above), but does not appear in IE6. The relevant CSS is as follows:

#div_nav { padding: 60px 0 0 0; background-image: url(images/01g_shop.gif); background-repeat: no-repeat; }

The XHTML ans CSS both validate. What gives? Am I missing something obvious regarding IE and the box model perhaps?

Deuce
Deuce's picture
Offline
Guru
Somewhere, USA
Last seen: 5 years 5 weeks ago
Somewhere, USA
Timezone: GMT-5
Joined: 2005-11-20
Posts: 4424
Points: 1843

try adding height: 60px to

try adding height: 60px to #div_nav

all ยป http://dictionary.reference.com/browse/all

Google isn't a bunch of guys reading and grading web sites, it's more like a bunch of monkeys sniffing food and putting the good bananas at the top. -Triumph

chikoppi
Offline
Enthusiast
Last seen: 11 years 35 weeks ago
Timezone: GMT-6
Joined: 2006-06-25
Posts: 85
Points: 2

Hm... the "div_nav" contains

Hm... the "div_nav" contains the menu, so height shouldn't be a problem. However... (!) as elements of the menu float maybe what I need to do is to apply a clearfix to the "div_nav" container to get it to wrap around the menu?

I'm going to give it a try and will let you know what happens.

P.S. The live code has been updated.

Crea
Crea's picture
Offline
Enthusiast
Hamburg - Germany
Last seen: 11 years 15 weeks ago
Hamburg - Germany
Timezone: GMT+2
Joined: 2007-02-08
Posts: 131
Points: 8

it appears on my IE

it appears on my IE 6.0.280.... atm

A perfection of means, and confusion of aims, seems to be our main problem.
Albert Einstein

http://www.creategg.de

chikoppi
Offline
Enthusiast
Last seen: 11 years 35 weeks ago
Timezone: GMT-6
Joined: 2006-06-25
Posts: 85
Points: 2

Crea wrote:it appears on my

Crea wrote:
it appears on my IE 6.0.280.... atm

Yup. It appears that IE6 needed to have the floats within the navigation list cleared in order for the #div_nav containing div to appear. I added the "clearfix" class to #div_nav and you can see the results below:

BEFORE: http://browsershots.org/screenshots/f08c67264581ab87006b62948a8e0fef/
AFTER: http://browsershots.org/screenshots/5f94d8c133d4474fe245c05a1b1483a3/

Thanks for lending a hand guys!