8 replies [Last post]
kHiTe
Offline
newbie
Last seen: 18 years 33 weeks ago
Joined: 2003-06-06
Posts: 7
Points: 0

FSOC

The above site seems to be working, but in I.E.6 under XP home on my PC text elements sometimes disappear. You can highlight the text making it visible, or resize the window to make it appear.

I am having no such problem in Opera or Mozilla.

It seems to really get upset if you go to full screen in I.E.

Is it my graphics drivers / set-up, is it I.E. and if so is there something I can do about it. :?

blakems
blakems's picture
Offline
Enthusiast
UTah, USA
Last seen: 18 years 42 weeks ago
UTah, USA
Timezone: GMT-7
Joined: 2003-04-07
Posts: 60
Points: 0

Text vanishes in I.E.6

I haven't seen any pecularities with the text disappearing and I am using IE6.0 XP.

I would check your graphics card or test other sites

-bMs-
http//www.blakems.com !important;

insin
insin's picture
Offline
Enthusiast
Belfast, NI
Last seen: 18 years 38 weeks ago
Belfast, NI
Joined: 2003-05-07
Posts: 57
Points: 0

Text vanishes in I.E.6

It might just be all your floats - IE hates them and likes to show you just how buggy it can be when you use loads of them. I see your text problems with IE6/Win2k.

I was making a site with a long floated left menu (my unfinished Metroid Prime competition entry - as I predicted, nearly all the winners showed only "Click here to get the plugin" when I looked at them in Firebird Wink), but hovering over the links in IE made the body text disappear inexplicably, so I had to resort to a table for cross-browserness :/

A Pedant Writes...
Into the mountain,
I will fall.

dJomp
dJomp's picture
Offline
Enthusiast
Last seen: 5 years 51 weeks ago
Joined: 2003-03-23
Posts: 422
Points: 0

Text vanishes in I.E.6

Ever read a PM on this forum? I know someone (not Tony I assume? Just reckon it's a public mod) has attempted to convert the PHPBB template to CSS, but that page just falls over in IE (well 6 at least). You have to highlight the text to see it...

You know you're a geek when you try to shoo a fly away from the monitor with your cursor.

Tony
Tony's picture
Offline
Moderator
Brisbane
Last seen: 1 week 3 days ago
Brisbane
Timezone: GMT+10
Joined: 2003-03-12
Posts: 5344
Points: 2965

Text vanishes in I.E.6

Thanks for pointing that out again DJomp.
I don't use IE unless I have to, but I must remember to do more testing. Wink

A missing end tag for a div was causing the text to disappear.

I managed to fix it but IE was still having problems rendering the page, something to do with 100% width. I took the easy way out and put a tabled version of the private message page back in.

Just a bit short of time at the moment to look any closer.

kHiTe
Offline
newbie
Last seen: 18 years 33 weeks ago
Joined: 2003-06-06
Posts: 7
Points: 0

Text vanishes in I.E.6

The problem seems to be random. Some people get it some don't.

Love the Metroid Site BTW.

Doesn't everyone use a Mozilla / Gecko browser now anyway?

paCkeTroUTer
paCkeTroUTer's picture
Offline
Enthusiast
Melbourne, Australia
Last seen: 8 years 37 weeks ago
Melbourne, Australia
Timezone: GMT+10
Joined: 2003-06-27
Posts: 241
Points: 2

Text vanishes in I.E.6

dJomp wrote:
Ever read a PM on this forum? I know someone (not Tony I assume? Just reckon it's a public mod) has attempted to convert the PHPBB template to CSS, but that page just falls over in IE (well 6 at least). You have to highlight the text to see it...

ok thinking about templating and the Smarty template Engine for php, has anyone used it ? I am planning to make a pure CSS site and implement CSS styled DIV's into the Templates. Would that work ? As far as my thinking goes... I am just replacing a table layout with a CSS styled layout. Any comments on that ?

cheers, Jeffery

http//melbourne.ug.php.net

kHiTe
Offline
newbie
Last seen: 18 years 33 weeks ago
Joined: 2003-06-06
Posts: 7
Points: 0

Removing Floats

As an alternative I removed some of the floats on the little 60x60 images and the problem went away. Aha! I said and positioned them absolutely from the left hand side of the page (putting them in the same place as before) and setting each image to align="left" so the text block went beside them.

Same problem. So it's not just floats, it's cutting out into text in general that I.E. had a problem with.

The thing is I now how to completely redesign the site for I.E.

>stabs arm in frustration<

kHiTe
Offline
newbie
Last seen: 18 years 33 weeks ago
Joined: 2003-06-06
Posts: 7
Points: 0

Solution!

Sorry to double Post.

The text that was vanishing was all text styled without a height. This inluded titles and subtitles as well as the main body introduction text at the top . In the articles themselves there seemed to be no problem. (fingers crossed)

I have placed the introduction text to each page in a box with a height and an auto overflow. I have given all the single line titles a height too.

Of course in I.E giving something a fixed height means that it makes it as wide as possible within fixed width or auto width boxs. So I had to play arround with some other stuff too.

Think it is almost fixed now tho.