8 replies [Last post]
OPTAdmin
Offline
Enthusiast
Dover, OH -- Soon to be Columbus, OH
Last seen: 18 years 18 weeks ago
Dover, OH -- Soon to be Columbus, OH
Joined: 2004-07-27
Posts: 108
Points: 0

http://www.ohiopreptalk.com/template/template.htm

Looks great in Firefox. Messes up a little bit in Opera. Functions in IE.

Help? Mainly with the top navigation bar, that seems to be the big problem.

I am going to be attending The Ohio State University this fall as an incoming freshman, majoring in Computer Science and Engineering.

Go Bucks!

OPTAdmin
Offline
Enthusiast
Dover, OH -- Soon to be Columbus, OH
Last seen: 18 years 18 weeks ago
Dover, OH -- Soon to be Columbus, OH
Joined: 2004-07-27
Posts: 108
Points: 0

Site check and help please

I'm pretty much done working on it within Firefox. I'm having a little trouble with the left navigation menu. When I hover over it, the border that I selected for it doesn't cover the entire box. So, I edited it to make it look as good as I could. See for yourself, of course.

Warning: Looks bad in IE.

I am going to be attending The Ohio State University this fall as an incoming freshman, majoring in Computer Science and Engineering.

Go Bucks!

Hugo
Hugo's picture
Offline
Moderator
London
Last seen: 7 years 47 weeks ago
London
Joined: 2004-06-06
Posts: 15668
Points: 2806

Site check and help please

That is pretty much it , with the left nav border have you tried what I suggested with the top nav in the other post try putting a display block on the .leftnav ul li a:hover but you will need to play around with other values as the text is shifting to the right a little when hovered and the border causes the dashed box to expand

The problem with IE is simply the use of the child selector, the display:none is not being seen by IE you just need to copy the top menu (which is working after a fashion) to the left-if you see what I mean - time to get working on IE find where the problem lies with the missing text (try what I suggested and remove the anchors as a test)

Hugo.

Before you make your first post it is vital that you READ THE POSTING GUIDELINES!
----------------------------------------------------------------
Please post ALL your code - both CSS & HTML - in [code] tags
Please validate and ensure you have included a full Doctype before posting.
Why validate? Read Me

OPTAdmin
Offline
Enthusiast
Dover, OH -- Soon to be Columbus, OH
Last seen: 18 years 18 weeks ago
Dover, OH -- Soon to be Columbus, OH
Joined: 2004-07-27
Posts: 108
Points: 0

Site check and help please

Little problem in IE.

With the left navigation bar, the list items that are popped up have a gap between them. I think I've put the margins and paddings to 0, so there really should be none. Any help please?

I am going to be attending The Ohio State University this fall as an incoming freshman, majoring in Computer Science and Engineering.

Go Bucks!

OPTAdmin
Offline
Enthusiast
Dover, OH -- Soon to be Columbus, OH
Last seen: 18 years 18 weeks ago
Dover, OH -- Soon to be Columbus, OH
Joined: 2004-07-27
Posts: 108
Points: 0

Site check and help please

New link:

http://www.ohiopreptalk.com/new/index.htm

Works properly in: Firefox v0.9.2, IE v6.0, Netscape 7.1

I thought I had fixed pretty much everything with the menus... until I looked at it in Opera v7.53. The top menu barely even displays.

Any help there?

I am going to be attending The Ohio State University this fall as an incoming freshman, majoring in Computer Science and Engineering.

Go Bucks!

thepineapplehead
thepineapplehead's picture
Offline
Moderator
Last seen: 31 weeks 3 days ago
Timezone: GMT+1
Joined: 2004-06-30
Posts: 9683
Points: 819

Site check and help please

It's getting there, but now I don't see the bg image.

Also, try displaying the menu itmes on the left as block, so you can hover over the grey space. You have to hover over the text to make the menus appear.

(FireFox 0.8 )

Verschwindende wrote:
  • CSS doesn't make pies

OPTAdmin
Offline
Enthusiast
Dover, OH -- Soon to be Columbus, OH
Last seen: 18 years 18 weeks ago
Dover, OH -- Soon to be Columbus, OH
Joined: 2004-07-27
Posts: 108
Points: 0

Site check and help please

The bg image no longer exists, that's why you don't see it. Smile

I can't quite figure out how to center the entire content, either. any help with that?

I fixed the left navigation menu, as well. It's coming along.

I am going to be attending The Ohio State University this fall as an incoming freshman, majoring in Computer Science and Engineering.

Go Bucks!

Hugo
Hugo's picture
Offline
Moderator
London
Last seen: 7 years 47 weeks ago
London
Joined: 2004-06-06
Posts: 15668
Points: 2806

Site check and help please

The way you have the structure set up at the moment needs to be revised as you don't have a container/ wrapper div to center on you've set text align center on the body you need auto margins and text align left on the wrapper the difficulty is going to be the elements within the main div as they are awkward now to center you will have to play around with margins and positioning. btw what is the id #body I don't see it in the CSS?

Hugo.

Before you make your first post it is vital that you READ THE POSTING GUIDELINES!
----------------------------------------------------------------
Please post ALL your code - both CSS & HTML - in [code] tags
Please validate and ensure you have included a full Doctype before posting.
Why validate? Read Me

OPTAdmin
Offline
Enthusiast
Dover, OH -- Soon to be Columbus, OH
Last seen: 18 years 18 weeks ago
Dover, OH -- Soon to be Columbus, OH
Joined: 2004-07-27
Posts: 108
Points: 0

Site check and help please

The body div is just for my own purposes right now. It really serves no purpose as of yet.

I am going to be attending The Ohio State University this fall as an incoming freshman, majoring in Computer Science and Engineering.

Go Bucks!