2 replies [Last post]
Turbonium
Offline
newbie
Last seen: 17 years 35 weeks ago
Joined: 2004-04-04
Posts: 5
Points: 0

site link

Try out the two themes, and go to the blog section (frontpage section) of the site. Now try clicking on the archived options on the right column (June 2004, etc.).

Something very strange happens (most of the time) in Firefox: if using one theme, it switches to the opposite theme when on an archive related page. It will switch back to the correc theme on any other page though. This does not happen in MSIE. I'm totally confused as to why this is happening.

The weird thing is, sometimes I'll try it, and it works in both MSIE and Firefox. I really am clueless as to what's happening.

Hugo
Hugo's picture
Offline
Moderator
London
Last seen: 6 years 47 weeks ago
London
Joined: 2004-06-06
Posts: 15668
Points: 2806

oddity in Firefox

Seems to work fine I can't see any problem in firefox 0.8, have you fixed it?

The only thing that springs to my mind is cookies; with styleswitcher it has to set a cookie each time you leave a page in order to remember your preference, maybe its not setting the cookie for some reason!

On a side note, slight worry, you need JavaScript to access your site at all would it not be an idea to provide alternative entry in case you loose the .js link or someones surfing with JavaScript turned off.

Sorry couldn't be more help,

Hugo.

Before you make your first post it is vital that you READ THE POSTING GUIDELINES!
----------------------------------------------------------------
Please post ALL your code - both CSS & HTML - in [code] tags
Please validate and ensure you have included a full Doctype before posting.
Why validate? Read Me

Turbonium
Offline
newbie
Last seen: 17 years 35 weeks ago
Joined: 2004-04-04
Posts: 5
Points: 0

oddity in Firefox

No, I didn't fix it.

And I didn't think of the JavaScript thing, oops. It will take way too long to fix it though. :?