4 replies [Last post]
m3rcury
Offline
newbie
Last seen: 13 years 9 weeks ago
Timezone: GMT-7
Joined: 2006-10-19
Posts: 8
Points: 0

Hello everyone,

I am new here..and I am just starting to learn CSS coding.

Here's the problem I have:

1) The navigation marker "you are here" works on IE 6.0 but it doesn't work for Firefox. Why is that?

2) Layout looks ok in IE but messed up in Firefox (there's an extended thin vertical line on the top of the main content)

Here's the css code:

body {
background-color: #faeed6;
margin: 0px;
font-family: Verdana, Arial, Helvetica, sans-serif;
font-size: 11px;
color: #666666;

}

/*Main body wrapper layout*/

#mainbody{
height: 400px;
width: 800px;
margin-top: 50px;
margin-left: 120px;
border: 2px solid #00cc99;
background-color: #FFFFFF;
position: relative;
margin-right: 120px;

}

/*Body copy container */

#bodycopy{
margin-top:100px;
margin-left:150px;
padding:10px;
width:350px;
position:absolute;

}

/*footnote*/

#footnote {
font-size:9px;
margin-left: 120px;
padding: 5px;
width: 800px;
text-align:center;

}

/*Link indicators "you are here" */

body#sidemenu a#sidemenupackaging,
body#sidemenu a#sidemenuidentity,
body#sidemenu a#sidemenulayout,
body#sidemenu a#sidemenuothers,
body#sidemenu a#sidemenuresume,

{
color:#ffffff;
background-color:#00cc99;
}

/*Vertical menu on subpages*/

#sidemenu {
width: 150px;
height:250px;
margin-top:100px;
border-right-width: 1px;
border-right-style: solid;
border-right-color: #b2a1cb;
position:absolute;

}

ul.verticalmenu{
margin:0px;
padding:0px;
position:relative;
}

ul.verticalmenu li {
list-style-type: none;
display: block;
text-align: right;
padding-right:20px;

}

ul.verticalmenu li a{
font-size:10px;
font-weight:bold;
color: #b2a1cb;
text-decoration:none;
padding: 5px;
line-height:40px;
}

ul.verticalmenu li a:link{
color: #b2a1cb;
}

ul.verticalmenu li a:visited{
color: #b2a1cb;
}

ul.verticalmenu li a:hover{
color:#faeed6;
background-color:#00cc99;
}

ul.verticalmenu li a:active{
color: #b2a1cb;

}

/*Resume page styles */

.heading {
color:#00cc99;
font-weight:bold;
margin:0px;
padding:0px;

}

.experiences {
color:#b2a1cb;
font-weight:bold;
margin:0px;
padding-top:5px;
padding-bottom:5px;
}

Here's the HTML cdes:

Packaging projects

  • PACKAGING
  • IDENTITY
  • LAYOUT
  • OTHERS
  • RESUME
  • HOME


BETTER WORKS THIS TIME!!!! Man, it's still not working as I want it to be! HELP!!!

© 2006 All rights reserved

I created these in notepad.

Thank you

Code tags added. Hugo.

Desdinova
Desdinova's picture
Offline
Enthusiast
Last seen: 8 years 34 weeks ago
Timezone: GMT+1
Joined: 2006-03-28
Posts: 341
Points: 4

probably because IE doesn't

probably because IE doesn't go with standards.

I believe you forgot closing one div, validate your html.

try placing a dot before the ID's in the stylesheet. just a thought, don't know if it'll make any difference.

ie. body.#sidemenu instead of body#sidemenu

As a rule, I never touch anything more sophisticated and delicate than myself

karinne
karinne's picture
Offline
Enthusiast
Aylmer, QC, Canada
Last seen: 14 years 6 weeks ago
Aylmer, QC, Canada
Timezone: GMT-5
Joined: 2004-01-14
Posts: 291
Points: 0

How about a link so we can

How about a link so we can actually see what's going wrong?

Mykkael
Mykkael's picture
Offline
newbie
Washington State
Last seen: 14 years 33 weeks ago
Washington State
Joined: 2006-10-19
Posts: 6
Points: 0

2 ID's the same

I was looking at your html code and noticed your body tag is designated id="sidemenu" and so is one of your div tags.

So the way you have it written, both are looking at the same place in your CSS. I am not sure how you want it to look, but I took the body id and made it "". It fixed your problem.

I hope that helps....

edit:::: oops I see you had your "you are here" nav linked to the id sidemenu. What I did to get that back is to make the body tag id="sidenav" and then I changed it in your CSS to match that.

/*Link indicators "you are here" */

body#sidenav a#sidemenupackaging,
body#sidenav a#sidemenuidentity,
body#sidenav a#sidemenulayout,
body#sidenav a#sidemenuothers,
body#sidenav a#sidemenuresume,

m3rcury
Offline
newbie
Last seen: 13 years 9 weeks ago
Timezone: GMT-7
Joined: 2006-10-19
Posts: 8
Points: 0

Yay!! It worked!! Thank you

Yay!! It worked!! Thank you very much!!!! Smile

ooh, I see now..on my previous code, I had 2 tags looking at the same ID..and of course it won't work...