4 replies [Last post]
bertalizer
Offline
newbie
Ghent - Belgium
Last seen: 15 years 19 weeks ago
Ghent - Belgium
Timezone: GMT+1
Joined: 2004-06-02
Posts: 3
Points: 0

Hi,

I'm having a very strange problem that only occurs on internet explorer 5 on Windows.

I've created a ul-navigation that uses background images as buttons. For the rollovers I'm using the great trick invented by pixy (fast rollovers without preload)
This works great.

Problem is, that I want to give the visitors a hint on where they are in the website, so I'm adding a class="youarehere" to the current items. These items get the same button as the rollover state. So I thought, let's reposition the background to the same position as the rollover for the youarehere class... well this works on every browser except IE5 Windows.
For now I've "solved" the problem by using a new unpositioned image for the youarehere class, but I really don't like doing it this way Sad

Please take a look here for an example (css is in the head):
http://socket-error.com/navprobs/

Any ideas, hints, hacks?
Thanks,
Bert

Tony
Tony's picture
Offline
Moderator
Brisbane
Last seen: 13 hours 35 min ago
Brisbane
Timezone: GMT+10
Joined: 2003-03-12
Posts: 5342
Points: 2963

IE5/PC not showing positioned background image

Hi bertalizer,
Have you thought of using text instead of an image for the text and just move the you are here arrow in the background.

asdf
Offline
newbie
Last seen: 15 years 19 weeks ago
Joined: 2004-06-01
Posts: 2
Points: 0

IE5/PC not showing positioned background image

This doesn't seem to work on IE5/Mac either. I've been struggling to get it to work using images as links while changing the position of the background image using CSS.

Seems that the image buttons are loading but somehow do not display. Its almost as if they are hiding behind the background image.

bertalizer
Offline
newbie
Ghent - Belgium
Last seen: 15 years 19 weeks ago
Ghent - Belgium
Timezone: GMT+1
Joined: 2004-06-02
Posts: 3
Points: 0

IE5/PC not showing positioned background image

Tony wrote:

Have you thought of using text instead of an image for the text and just move the you are here arrow in the background.

I wanted to do it that way but the designer insisted on using the pixel font.

Thanks,
B.

bertalizer
Offline
newbie
Ghent - Belgium
Last seen: 15 years 19 weeks ago
Ghent - Belgium
Timezone: GMT+1
Joined: 2004-06-02
Posts: 3
Points: 0

IE5/PC not showing positioned background image

asdf wrote:
This doesn't seem to work on IE5/Mac either. I've been struggling to get it to work using images as links while changing the position of the background image using CSS.

Seems that the image buttons are loading but somehow do not display. Its almost as if they are hiding behind the background image.

I don't know how you are trying to do it, but the way I'm doing it works on IE/Mac.

B.