10 replies [Last post]
Dranore
Offline
newbie
Last seen: 18 years 13 weeks ago
Timezone: GMT-5
Joined: 2004-05-09
Posts: 7
Points: 0

Hi. I'm just trying to finish up my first fully CSS designed site. In the process of testing different browsers, IE 5.2 for Mac seems to be ignoring my font-family code. I believe IE for Win is doing it as well. I have this same code pasted redundantly for each DIV section just to make sure. The line reads as follows:

font-family:Arial,"Arial", sans-serif;

That was what I changed it to experimenting. It used to say:

font-family:Arial, sans-serif;

Not sure what the issue might be. Can anyone help me out? The link to the actual file, if you need to check something, is here:

http://www.bethisraelmalden.com/layout.css

Thanks for the assistance.

-C. Richardson

ClevaTreva
ClevaTreva's picture
Offline
Guru
A hilly place, UK
Last seen: 3 years 40 weeks ago
A hilly place, UK
Joined: 2004-02-05
Posts: 2902
Points: 0

IE 5.2 Mac not reading font-family???

Hi

Aside from the fact that my font-family is all lowercase and offers verdana as an alternative, like this:

font-family:verdana,arial,sans-serif;

I can't see why you have a problem. The mac you are testing it on DOES have arial installed?

Trevor

Dranore
Offline
newbie
Last seen: 18 years 13 weeks ago
Timezone: GMT-5
Joined: 2004-05-09
Posts: 7
Points: 0

IE 5.2 Mac not reading font-family???

Yeah, it has Arial. Wink The page looks fine in Safari. But my IE still insists upon using what looks like Georgia or Times, even after using your code. Hmm...

UPDATE: I tried it on my girlfriend's computer in her IE, but it doesn't function. Very strange.

ClevaTreva
ClevaTreva's picture
Offline
Guru
A hilly place, UK
Last seen: 3 years 40 weeks ago
A hilly place, UK
Joined: 2004-02-05
Posts: 2902
Points: 0

IE 5.2 Mac not reading font-family???

Hi

Can you post a link to the css so we can take a look at the whole file?

Trevor

Dranore
Offline
newbie
Last seen: 18 years 13 weeks ago
Timezone: GMT-5
Joined: 2004-05-09
Posts: 7
Points: 0

IE 5.2 Mac not reading font-family???

Check the first post for the css link... remove the layout.css to see the actual page. Thanks again for looking.

-C. Richardson

co2
co2's picture
Offline
Leader
UK
Last seen: 14 years 17 weeks ago
UK
Joined: 2003-09-17
Posts: 721
Points: 0

IE 5.2 Mac not reading font-family???

Very strange. I check your site in IE5 OS X and get serif as well. I checked your code and it seems fine. However, I downloaded your HTML and CSS and saved them to my server and it shows as Arial in IE5, correctly.

Here's the page on my server: http://pub.c-o2.net/cssf/dranore.htm

As you will see, I have not changed one bit of your code... I've even created a http:// link to your css page on-line.

I presume it could be the way the file is saved. What application did you use to write the code? I saved the code in BBEdit. When I first saved and viewed it from BBEdit, in IE5, it was showing a characteristic page encoding problem (normally presents two question marks in the upper-left of the page... these are encoding characters that shouldn't be visible).

The next sentence is true. The previous sentence is false. Discuss...

Dranore
Offline
newbie
Last seen: 18 years 13 weeks ago
Timezone: GMT-5
Joined: 2004-05-09
Posts: 7
Points: 0

IE 5.2 Mac not reading font-family???

Thanks for the info. I'll try resaving the code in another program. I had originally written it in Dreamweaver MX 2004 while working on the layout. However, I'm assuming that's what's causing the problem. Thanks for the lead. I'll give it a try and post the results. Good thing to know if Dreamweaver is messing up some of my CSS. Thanks.

-C. Richardson

Dranore
Offline
newbie
Last seen: 18 years 13 weeks ago
Timezone: GMT-5
Joined: 2004-05-09
Posts: 7
Points: 0

IE 5.2 Mac not reading font-family???

I'm tired. Perhaps I'm confused. I recall looking at your link... seeing it in Arial... and now I've made some form of change to the CSS file and now even your link doesn't work. I'm really not sure what's going on. I opened everything in BBEdit... no weird characters... even tried different encodings... no go. I still get nice Arial in Safari... but serif font in IE 5.2. Really have no idea why at this point. Also, if I did in fact see your page working... I don't know why it stopped... ::sigh:: This is really irritating for something so simple.

co2
co2's picture
Offline
Leader
UK
Last seen: 14 years 17 weeks ago
UK
Joined: 2003-09-17
Posts: 721
Points: 0

IE 5.2 Mac not reading font-family???

Try linking to your stylesheet with the <link...> tag rather than: @import "layout.css";

The next sentence is true. The previous sentence is false. Discuss...

Dranore
Offline
newbie
Last seen: 18 years 13 weeks ago
Timezone: GMT-5
Joined: 2004-05-09
Posts: 7
Points: 0

IE 5.2 Mac not reading font-family???

Good thought, but it didn't work. :\ Man this is frustrating.

Also, one new(?) problem. Also in IE 5.2 the browser seems to be breaking with the right div... meaning there is an unremovable green border running down the right side for no apparent reason, when it should be flush. If someone knows a quick fix for this, I'd appreciate it. Thanks again to everyone who's attempted to help me.

Dranore
Offline
newbie
Last seen: 18 years 13 weeks ago
Timezone: GMT-5
Joined: 2004-05-09
Posts: 7
Points: 0

IE 5.2 Mac not reading font-family???

W00t! I figured out the font issue. It turns out the meta tag in the document pertained to font encoding and I just sort of ignored it untill I went through it line by line after I tested the CSS with a new page. I didn't write the page originally, so the stupid meta tag overode my font style sheet. Phew. Glad that's fixed, however; I still need a solution to making the page play nice in IE 5.2 for mac in terms of getting the right side of the page to be flush. :\ Any tips would, again, be appreciated.