10 replies [Last post]
mediagirl
Offline
newbie
Last seen: 14 years 32 weeks ago
Joined: 2006-03-09
Posts: 4
Points: 0

<<<Post removed>>>

thepineapplehead
thepineapplehead's picture
Offline
Guru
Last seen: 31 weeks 19 hours ago
Joined: 2004-06-30
Posts: 9668
Points: 801

Very weird problem in IE - Need help troubleshooting

Remove the comments.

<!-- HEADER START -->

I'm afraid as this is before the DTD, it's throwing IE into Quirks Mode. See if that helps.

Verschwindende wrote:
  • CSS doesn't make pies

mediagirl
Offline
newbie
Last seen: 14 years 32 weeks ago
Joined: 2006-03-09
Posts: 4
Points: 0

Very weird problem in IE - Need help troubleshooting

Removing the comment didn't do the trick...

Also, I just added the complete HTML code above as my first version wasn't including the header/footer/left nav and right nave... I have those set up as includes...

Tyssen
Tyssen's picture
Offline
Moderator
Brisbane
Last seen: 6 years 1 week ago
Brisbane
Timezone: GMT+10
Joined: 2004-05-01
Posts: 8201
Points: 1386

Very weird problem in IE - Need help troubleshooting

<img src="http://www.mediagirl.com/~nmitsa/images/site/lg-dotted.gif" height="19" width="368">

That's too wide. You don't really need an image for it when you could use a <hr /> or a bottom border instead. Also, you've overused your <h1> tags. H1s are generally reserved for the largest heading on the page and it's recommended they only be used once.

How to get help
Post a link. If you can't post a link, jsFiddle it.
My blog | My older articles | CSS Reference

mediagirl
Offline
newbie
Last seen: 14 years 32 weeks ago
Joined: 2006-03-09
Posts: 4
Points: 0

Very weird problem in IE - Need help troubleshooting

Thank you on the h1 advise. I will address this in my code...

Also, thank you for pointing me to the image as the problem. I'm using an image because I want the dotted line instead of a solid line. Dotted lines using CSS don't appear correctly in IE so I'm using an image instead. I will try adjusting the size.

Thank you for taking the time to look at my code. Very appreciated.

Tyssen
Tyssen's picture
Offline
Moderator
Brisbane
Last seen: 6 years 1 week ago
Brisbane
Timezone: GMT+10
Joined: 2004-05-01
Posts: 8201
Points: 1386

Very weird problem in IE - Need help troubleshooting

mediagirl wrote:
I'm using an image because I want the dotted line instead of a solid line.

Fair enough if you want a particular type of dotted line but at the moment your image looks like a solid line.

How to get help
Post a link. If you can't post a link, jsFiddle it.
My blog | My older articles | CSS Reference

Ed Seedhouse
Ed Seedhouse's picture
Offline
Guru
Victoria British Columbia
Last seen: 43 weeks 5 days ago
Victoria British Columbia
Timezone: GMT-8
Joined: 2005-12-14
Posts: 3570
Points: 675

Very weird problem in IE - Need help troubleshooting

Quote:
The site is built using Expression Engine as a content management system.

Well your CMS seems to be putting out a whole lot of illegal xhtml, and that sort of thing tends to mess up browsers, even highly compliant ones.

I've found this to be a general problem with almost all the CMS systems I've tested, alas.

Anyone know a CMS that actually puts out valid xhtml, as opposed to merely claiming that it does?

Ed Seedhouse

Posting Guidelines

Watch out! I am carrying irony, sarcasm and satire, and know how to use them.

Tyssen
Tyssen's picture
Offline
Moderator
Brisbane
Last seen: 6 years 1 week ago
Brisbane
Timezone: GMT+10
Joined: 2004-05-01
Posts: 8201
Points: 1386

Very weird problem in IE - Need help troubleshooting

I don't think Expression Engine's to blame in this case. It's actually one I've been looking at recently and it seems to do a pretty good job. I mean, mostly it's only going to output what you put into it.

Here's a couple of examples using EE which pass validation:

http://www.lealea.net/blog/
http://veerle.duoh.com/

How to get help
Post a link. If you can't post a link, jsFiddle it.
My blog | My older articles | CSS Reference

thepineapplehead
thepineapplehead's picture
Offline
Guru
Last seen: 31 weeks 19 hours ago
Joined: 2004-06-30
Posts: 9668
Points: 801

Very weird problem in IE - Need help troubleshooting

Ed Seedhouse wrote:
Anyone know a CMS that actually puts out valid xhtml, as opposed to merely claiming that it does?

Wordpress, as suggested by Jeffrey Zeldman here:

http://www.zeldman.com/wordpress/

Verschwindende wrote:
  • CSS doesn't make pies

HellsBells
HellsBells's picture
Offline
Leader
Bedford, UK
Last seen: 12 years 25 weeks ago
Bedford, UK
Joined: 2004-04-07
Posts: 851
Points: 0

Very weird problem in IE - Need help troubleshooting

I second the Wordpress suggestion - especially for clients who really want a Word like input environment.

Also there's this: http://greenbeastcms.com/

My strategy is so simple an idiot could have devised it!

"Also, your CSS (no offence) makes me want to gouge my eyes out with a rusty spoon" - TPH

mediagirl
Offline
newbie
Last seen: 14 years 32 weeks ago
Joined: 2006-03-09
Posts: 4
Points: 0

Very weird problem in IE - Need help troubleshooting

The validation failure is my fault not Expression Engines. The software is great and it's what I use for all my projects.

The site is in production and not live. I do validation tests prior to launch when I do my thourough browser testing.