11 replies [Last post]
g4oliver
Offline
newbie
Last seen: 16 years 25 weeks ago
Timezone: GMT-5
Joined: 2004-04-01
Posts: 8
Points: 0

I'm working on a website for a friend, and of course, I'm running into some compatibility problems. I'm using XHTML and CSS, and for some reason, the navbar and the banner graphic are drawing 12px to the left of where they are in Netscape, IE Mac, Safari, Mozilla, and almost every other browser.

Another oddity is that Opera Mac (and possibly Win) has the same problem as IE Win, until I increase Opera's page zoom to 500% and then decrease it back to 100%. Then, Opera displays the page correctly, just as Netscape would. One Opera rendering bug that I am not sure is fixable is the hover effect on the navbar. The button divider disappears on hover, and no image change takes place.

If anyone could be so kind as to point me to the portion of the code that is causing the problem in IE (and Opera), I'd be quite thankful Laughing out loud.

The web page is temporarily located at http://homepage.mac.com/g4oliver/paintedfishgallery/ , and the CSS file is http://homepage.mac.com/g4oliver/paintedfishgallery/paintedfish.css .

Cheers !
- Oliver

ClevaTreva
ClevaTreva's picture
Offline
Guru
A hilly place, UK
Last seen: 1 year 46 weeks ago
A hilly place, UK
Joined: 2004-02-05
Posts: 2902
Points: 0

MSIE Win does it again

Hi

Ok, the IE problem is the largecaption style width, take it out and the problem goes away, and it doesn't seem to affect Firefx 0.8 if you do.

Trevor

g4oliver
Offline
newbie
Last seen: 16 years 25 weeks ago
Timezone: GMT-5
Joined: 2004-04-01
Posts: 8
Points: 0

weird

wow, thanks for the quick help on such a weird problem! I temporarily disabled largecaption and it works in MSIE Win. however, the similar problem in Opera still persists. Hmm...

Thanks !!
- Oliver

g4oliver
Offline
newbie
Last seen: 16 years 25 weeks ago
Timezone: GMT-5
Joined: 2004-04-01
Posts: 8
Points: 0

IE Win

Uhoh, the IE Win problem isn't fixed. It's got the same problem, just now, instead of 12px to the left, it's only 1px. Suggestions ne1?

ClevaTreva
ClevaTreva's picture
Offline
Guru
A hilly place, UK
Last seen: 1 year 46 weeks ago
A hilly place, UK
Joined: 2004-02-05
Posts: 2902
Points: 0

MSIE Win does it again

Hi

I didn't say kill the whole style, just the width.

I have found a bug with IE before with a centered design that centers the main container with text-align:center; in the body for IE

AND where

the maincontent (your name) page container doesn't reset the text-align back to the default (left), then any container that should fit in the main container jumps out by one pixel.

Maybe that's the problem.

Trevor

g4oliver
Offline
newbie
Last seen: 16 years 25 weeks ago
Timezone: GMT-5
Joined: 2004-04-01
Posts: 8
Points: 0

Ahem

Hmm, I've tried playing about with the mainpage and maincontent styles, and the problem in IE persists as long as mainpage is centered. I've made the text-aligns of both mainpage and maincontent "left", I've even tried putting the banner and navbar in a DIV of their own, IE is still drawing the top part of the page 1px to the left. Also, IE is placing everything in maincontent several pixels to the right of where it should be.

What part of the CSS do I need to change?

ClevaTreva
ClevaTreva's picture
Offline
Guru
A hilly place, UK
Last seen: 1 year 46 weeks ago
A hilly place, UK
Joined: 2004-02-05
Posts: 2902
Points: 0

MSIE Win does it again

Hi

I just went to the url again, and it looks all aligned correctly in IE6.

What version of IE are you using?

However, the content and image are not centered, being a bit to the right of center.

But the nav bar is not overlapping the main container box.

Trevor

g4oliver
Offline
newbie
Last seen: 16 years 25 weeks ago
Timezone: GMT-5
Joined: 2004-04-01
Posts: 8
Points: 0

IE Ver

I'm using IE Win 6.0.2600 on this PC... perhaps I'll get the latest version.

ClevaTreva
ClevaTreva's picture
Offline
Guru
A hilly place, UK
Last seen: 1 year 46 weeks ago
A hilly place, UK
Joined: 2004-02-05
Posts: 2902
Points: 0

MSIE Win does it again

Hi,

Can't see that as the problem, as mine is 6.0.2800 PC

Odd.

Trevor

g4oliver
Offline
newbie
Last seen: 16 years 25 weeks ago
Timezone: GMT-5
Joined: 2004-04-01
Posts: 8
Points: 0

404

ClevaTreva,

Thanks for all your help with this Smile

The site's now at www.paintedfishgallery.com .

Weird, I still see that 1px problem with the latest update to IE (from www.microsoft.com/ie) on both Windows 98 and Windows XP Pro.

Excavator
Excavator's picture
Offline
Enthusiast
Alaska
Last seen: 5 years 40 weeks ago
Alaska
Timezone: GMT-9
Joined: 2004-04-04
Posts: 121
Points: 60

MSIE Win does it again

Looks good here on IE6.
I like the how you color the tab on the menu with the page your on and that's not working right now for the Calendar, Location and Gallery tabs.

That one pixel goof your talking about... is that how the Home tab takes away the border when it's colored? I have that here. /img
Excellent website though - sent it to my Mother.

edit - forgot to tell you what versions.

XP Pro machines with
IE 6.0.2800
Mozilla 1.7b
Opera 7.23

g4oliver
Offline
newbie
Last seen: 16 years 25 weeks ago
Timezone: GMT-5
Joined: 2004-04-01
Posts: 8
Points: 0

Border

Yeah, you got the s'shot there, that's the one... but, there was never a border there, and it's like that on all pages. Also, the title graphic is 1px to the left, as well. And only in IE.

You're not seeing the tab colored for the unfinished pages because you're just getting a 404 error (which happens to be an UNDER CONSTRUCTION error for now).

And I hope your mother likes the site, Excavator Smile.