3 replies [Last post]
axiom1
Offline
Regular
Australia
Last seen: 13 years 43 weeks ago
Australia
Joined: 2006-01-18
Posts: 11
Points: 0

Thanks in advance for your help. This is the first time I've tried css.

I am attempting to use background images. They show correctly in IE6, but don't appear in Firefox.

Here is the url: http://www.axiom1.net/axiom_template_2006_ver4_master.htm

My css is here: http://www.axiom1.net/axiom_web.css

My CSS code is:
.banner { background: transparent url(AXIOMBANNER06.jpg) background: no-repeat; color: #000; width: 736px !important;
height: 85px !important; }

.bgimage { background: transparent url(AASC_Logo.jpg) background: no-repeat; color: #000; width: 195px !important;
height: 51px !important; }

The html is:
<tr>
<td width="18" rowspan="2">
<img border="0" src="images/spacer.gif" width="18" height="1"></td>
<td colspan="4" rowspan="2" bgcolor="#FFFFFF">
<p class="banner">&nbsp;</td>
<td width="18" rowspan="2">
<img border="0" src="images/spacer.gif" width="18" height="1"></td>
<td width="196" colspan="2" align="right" valign="bottom" height="69">
<p class="bgimage" align="left">&nbsp;</td>
<td width="17" bgcolor="#FFFFFF" rowspan="2">&nbsp;</td>
</tr>
<tr>
<td width="196" colspan="2" align="right" valign="bottom">
<p class="nav"><a href="http://www.axiom1.com.au/">
home</a>&nbsp;|
<a href="site_map.htm">sitemap&nbsp;</a> l
<a href="axiom_web.css">contact us</a>&nbsp;
</td>
</tr>

In the head I have:
<head>
<link rel="stylesheet" type="text/css" href="axiom_web.css">
</head>

I'd be grateful if someone could tell me where I am going wrong.

Thanks.

wolfcry911
wolfcry911's picture
Offline
Guru
MA, USA
Last seen: 5 years 36 weeks ago
MA, USA
Timezone: GMT-5
Joined: 2004-09-01
Posts: 3224
Points: 237

Background image showing in IE6, but not in Firefox

.banner { background: transparent url(AXIOMBANNER06.jpg) background: no-repeat; color: #000; width: 736px !important;
height: 85px !important; }

.bgimage { background: transparent url(AASC_Logo.jpg) background: no-repeat; color: #000; width: 195px !important;
height: 51px !important; }

Remove the red (background:) part

axiom1
Offline
Regular
Australia
Last seen: 13 years 43 weeks ago
Australia
Joined: 2006-01-18
Posts: 11
Points: 0

Background image showing in IE6, but not in Firefox

Hi wolfcry911,

Thanks so much for your help. I've removed 'background' as you directed, but it is still not working. (However, when I preview in Firefox from FrontPage 2003, it is now working.)

axiom1
Offline
Regular
Australia
Last seen: 13 years 43 weeks ago
Australia
Joined: 2006-01-18
Posts: 11
Points: 0

Background image showing in IE6, but not in Firefox

Hi wolfcry911,

Sorry, my mistake. It is now working thanks to your help.