3 replies [Last post]
qwiksilver
Offline
newbie
Last seen: 15 years 17 weeks ago
Joined: 2005-12-13
Posts: 1
Points: 0

I've set up some css, part of which is for the links menu (.SelectedLinkBox{}), that outputs an image when that link is selected. For some reason it's not working on my new server.

Note Working: http://www.nickita.co.uk/delc/help_desk.php
Working: http://www.onyxtec.com/client/delc/pre_release/help_desk.php

Any ideas? Thanks in advance..

The css code:

/* ===================================================================== */
/* Copyright 2005, DELC */
/* Created by Justin Davis (OnyxTec.com) */
/* ===================================================================== */
/*
a:link{}
a:visited{}
a:hover{}
a:active{}
*/

body {
	scrollbar-arrow-color: #FFFFFF;
	scrollbar-base-color: #3C0B11;
	scrollbar-shadow-color: #993399;
	scrollbar-face-color: #993399;
	scrollbar-highlight-color: #F3F3F3;
	scrollbar-dark-shadow-color: #FFFFFF;
	scrollbar-3d-light-color: #3C0B11;
}
.body {
	font-family: Verdana, Arial, Helvetica, sans-serif;
	font-size: 12px;
	color: #333333;
	font-weight: normal;
	font-style: normal;
	line-height: 18px;
	text-align: justify;
}
.title {
	font-family: Verdana, Arial, Helvetica, sans-serif;
	font-size: 12px;
	color: #333333;
	font-weight: bold;
	font-style: normal;
	line-height: 20px;
}
.photoBoarder {
	border: 1pt solid #333333;
}
.bodySmall {
	font-family: Verdana, Arial, Helvetica, sans-serif;
	font-size: 7pt;
	color: #333333;
	font-weight: normal;
	font-style: normal;
	line-height: 18px;
}
.formErrorMessage {
	font-family: Verdana, Arial, Helvetica, sans-serif;
	font-size: 7pt;
	color: #FF0000;
	font-weight: bold;
	font-style: normal;
	line-height: 18px;
}
.formTitleText{
	font-family: Times New Roman, Times, serif;
	font-size: 18pt;
	color: #0000ff;
	font-weight: normal;
	font-style: normal;
	line-height: 24px;
}
.linkText {
	font-family: Verdana, Arial, Helvetica, sans-serif;
	font-size: 8pt;
	color: #FFFFFF;
	font-weight: bold;
	font-style: normal;
	line-height: 34px;
	vertical-align: middle;
	text-indent: 3pt;
}
.subLinkText {
	font-family: Verdana, Arial, Helvetica, sans-serif;
	font-size: 8pt;
	color: #FFFFFF;
	font-weight: normal;
	font-style: normal;
	line-height: 34px;
	vertical-align: middle;
	text-indent: 3pt;
}
.footerLinks {
	font-family: Verdana, Arial, Helvetica, sans-serif;
	font-size: 7pt;
	color: #333333;
	font-weight: normal;
	font-style: normal;
	line-height: 26px;
}
.SelectedLinkBox {
	font-family: Verdana, Arial, Helvetica, sans-serif;
	font-size: 8pt;
	color: #FFFFFF;
	font-weight: bold;
	font-style: normal;
	line-height: 34px;
	vertical-align: middle;
	text-indent: 5pt;
	
	background-image: url(../images/selected_link_big.jpg);
	background-repeat: no-repeat;
	background-position: left center;
}
.mailTitle {
	font-family: Verdana, Arial, Helvetica, sans-serif;
	font-size: 30px;
	color: #660066;
	font-weight: normal;
	font-style: normal;
	line-height: 20px;
	text-indent: 10pt;

}
.mailTitle2nd {
	font-family: Verdana, Arial, Helvetica, sans-serif;
	font-size: 26px;
	color: #660066;
	font-weight: normal;
	font-style: normal;
	line-height: 20px;
	text-indent: 10pt;
}
.SelectedSubLinkBox {

	font-family: Verdana, Arial, Helvetica, sans-serif;
	font-size: 8pt;
	color: #FFFFFF;
	font-weight: normal;
	font-style: normal;
	line-height: 34px;
	vertical-align: middle;
	text-indent: 5pt;
	
	background-image: url(../images/selected_sub_link_big.jpg);
	background-repeat: no-repeat;
	background-position: left center;
}

Anonymous
Anonymous's picture
Guru

css working on one server but not the other???

You really need to validate your markup. Not only don't you have a doctype declaration, you also don't have <html> tags.

That would probably be a first step.

ClevaTreva
ClevaTreva's picture
Offline
Guru
A hilly place, UK
Last seen: 2 years 23 weeks ago
A hilly place, UK
Joined: 2004-02-05
Posts: 2902
Points: 0

css working on one server but not the other???

Hi

The css you have starts with this:

/* ===================================================================== */
/* Copyright 2005, DELC */
/* Created by Justin Davis (OnyxTec.com) */
/* ===================================================================== */
<STYLE TYPE="text/css">
/*

The style type line shouldn't be in an external file, should it? The end style tag is there too at the end of the file. Try it without them.

Trevor

Anonymous
Anonymous's picture
Guru

css working on one server but not the other???

ClevaTreva wrote:
Hi

The css you have starts with this:

/* ===================================================================== */
/* Copyright 2005, DELC */
/* Created by Justin Davis (OnyxTec.com) */
/* ===================================================================== */
<STYLE TYPE="text/css">
/*

The style type line shouldn't be in an external file, should it? The end style tag is there too at the end of the file. Try it without them.Ah, something validation would have revealed.