7 replies [Last post]
Joff
Joff's picture
Offline
Regular
Leeds, UK
Last seen: 11 years 5 days ago
Leeds, UK
Joined: 2005-07-22
Posts: 37
Points: 0

Hello style people,

I would massively appreciate anyone who has a Mac and can help me out on this issue.
Okay, the site that I've just designed is my first attempt at using a purely CSS based approach:

http://www.las.uk.net/

The site renders okay in IE, FF and Netscape, but I believe that there are problems with the box model in Safari.

Should I be using absolute positioning?
Help! Please!

wolfcry911
wolfcry911's picture
Offline
Guru
MA, USA
Last seen: 7 years 4 days ago
MA, USA
Timezone: GMT-5
Joined: 2004-09-01
Posts: 3224
Points: 237

Box Model Problems in Safari

There is no difference between Safari 1.3.1 and FF/Mac. I saw nothing resembling a box model problem. To the best of my knowledge, Safari never had such a problem - only IE.

Joff
Joff's picture
Offline
Regular
Leeds, UK
Last seen: 11 years 5 days ago
Leeds, UK
Joined: 2005-07-22
Posts: 37
Points: 0

Box Model Problems in Safari

Ok. Thanks for this info.
The problem only seems to arise on the Mac browser, both in Safari and Mac/IE. Although FF on the Mac displays fine.
Surely this must be something to do with the rendering engine on Apple?
The problem can be seen on the homepage and the news page.

Anonymous
Anonymous's picture
Guru

Box Model Problems in Safari

I see no problem. Perhaps you could take a screen shot to explain the problem more clearly.

Joff
Joff's picture
Offline
Regular
Leeds, UK
Last seen: 11 years 5 days ago
Leeds, UK
Joined: 2005-07-22
Posts: 37
Points: 0

screenshot

Good idea!

Okay, here's the screenshot in Safari:

wolfcry911
wolfcry911's picture
Offline
Guru
MA, USA
Last seen: 7 years 4 days ago
MA, USA
Timezone: GMT-5
Joined: 2004-09-01
Posts: 3224
Points: 237

Box Model Problems in Safari

It looked okay in Safari 1.3.1 for me. What version are you using?

Joff
Joff's picture
Offline
Regular
Leeds, UK
Last seen: 11 years 5 days ago
Leeds, UK
Joined: 2005-07-22
Posts: 37
Points: 0

Box Model Problems in Safari

I'm using an older version of Safari (v1.0.3) running on OS 10.2.8.

It's also rendering wrong on Mac/IE v5.2:



Does anyone else know if there's a fix for this?

ragamuffin
ragamuffin's picture
Offline
Leader
Iowa
Last seen: 11 years 51 weeks ago
Iowa
Joined: 2005-06-02
Posts: 691
Points: 0

Box Model Problems in Safari