1 reply [Last post]
alefmemalef
Offline
newbie
Last seen: 4 years 32 weeks ago
Timezone: GMT+3
Joined: 2010-05-11
Posts: 2
Points: 3

Hi,
I've built two Joomla websites with dropdown menus and am having endless struggles with the menus.

In the first website the CssMenu works beautifully in IE8, FF and Safari. But in IE7 the menu is evasive and disppears once you try and go below the second item. In IE6 I have the same problem on my local server but when I upload the site to the hosting server, the dropdown menu does not open at all.
This is the website - www.rga.co.il.

The second website is even worse and I am still trying to solve it on my local server. At the moment the uploaded website is using Superfish menu but since I can't align the dropdown menu to the right, it is flawed. I first used swMenuFree on both websites but discovered to my horror that when viewed on wide screens, the drop downmenu gets relocated to the right of the screen.
In this website my design dictates that the dropdown menu will open a few pixels under the top menu, under a bottom-border, which, I assume is what is causing the problem. So even in IE8, when the page is first entered, the dropdown menu acts up - showing for a second and then disappearing. After a few seconds, it becomes usable. The gallery pages are even worse and the dropdown menu, which is meant to open over the large photo of the gallery, disappears once you try to select from it.
This is the website - www.studio-nof.co.il.

Help !!! P-l-e-a-s-e !!!

alefmemalef
Offline
newbie
Last seen: 4 years 32 weeks ago
Timezone: GMT+3
Joined: 2010-05-11
Posts: 2
Points: 3

Prolem solved

Hi,
The problem has been solved with the kind help of Ken in the Joomla forum.
The problem with the gallery pages required some more work and was to do with the top margin of the large photo overlapping with the hover area of the top menu.
Smile