5 replies [Last post]
oneeezy
oneeezy's picture
Offline
Enthusiast
Beaumont, TX
Last seen: 2 years 32 weeks ago
Beaumont, TX
Timezone: GMT-6
Joined: 2009-11-18
Posts: 98
Points: 126

Ok, I'm editing a phpbb website right now, please have a look: www.phone7forum.com

My problem is I'm building a liquid layout (when you expand the window the div tags expand as well..) It has a sidebar and main content section. The sidebar is a fixed width and main content area is expandable. So my problem is I have the sidebar floated to the left and the content floated to the left hoping they will line up side by side but they do not.. and I can't add a fixed width to the content because it will not be expandable anymore.. and when i add a percentage for width it works for a second but then when window expands down it will "return" to the bottom. This would be an easy fix but because I have to work with phpbb it changes things up a bit. So I guess Im stuck and out of ideas at this point. And thats when i come here! So guys, if you know what I should do please let me know..

Thanks!
Justin

http://oneillwebs.com/ ~ yes, my personal website built purely with tables which needs to be updated heavily Wink

(before i knew anything!)

oneeezy
oneeezy's picture
Offline
Enthusiast
Beaumont, TX
Last seen: 2 years 32 weeks ago
Beaumont, TX
Timezone: GMT-6
Joined: 2009-11-18
Posts: 98
Points: 126

Id also like to add that when

Id also like to add that when I don't have a float on the "content" The first part "phone 7 forum" will line up correctly with the side bar and work fine. I just can't get the actual "forum stuff" to go up and sit underneath it.

http://oneillwebs.com/ ~ yes, my personal website built purely with tables which needs to be updated heavily Wink

(before i knew anything!)

oneeezy
oneeezy's picture
Offline
Enthusiast
Beaumont, TX
Last seen: 2 years 32 weeks ago
Beaumont, TX
Timezone: GMT-6
Joined: 2009-11-18
Posts: 98
Points: 126

ok, well i thot i had the

ok, well i thot i had the problem fixed but i do not... will someone please check it out for me? the content is still not coming up to the top. . .

http://oneillwebs.com/ ~ yes, my personal website built purely with tables which needs to be updated heavily Wink

(before i knew anything!)

regia
regia's picture
Offline
Enthusiast
San Diego
Last seen: 3 weeks 5 days ago
San Diego
Timezone: GMT-4
Joined: 2010-10-24
Posts: 307
Points: 347

I'm not quite sure what you

I'm not quite sure what you want as you are not naming the divs, but if you remove clear:both from .forabg the whole panel moves up.

oneeezy
oneeezy's picture
Offline
Enthusiast
Beaumont, TX
Last seen: 2 years 32 weeks ago
Beaumont, TX
Timezone: GMT-6
Joined: 2009-11-18
Posts: 98
Points: 126

Hey Regia, It's a pre-made

Hey Regia,
It's a pre-made forum so a lot of the CSS in there is not mine unfortunately... So i did what you said and deleted that clear: both and it brought up the content but some of its still staying at the bottom for some reason??

Everything seemed to be working fine until i started adding in the forum code inside my custom div boxes. I think it has something to do w/ the css that came in the pre-made forum but im not completly sure.. What its doing is taking the content of whats inside the forum divs and expanding it all the way down until it gets to the end of the sidebar.., then it shows more content.

Take a look at this:
http://www.phone7forum.com/viewtopic.php?f=2&t=4
http://www.phone7forum.com/viewforum.php?f=2
(and this is only on 2 pages.., there are more like this)

The first link shows the post expanding all the way down to the end of the sidebar and then the other 2 posts are listed under that.. and the 2nd link has the bg color expanding all the way down..Do you think this is another clear:both misused somewhere? What do you think the problem is?

This is what I'm trying to achieve:
1st Link - Desired Effect
2nd Link - Desired Effect

http://oneillwebs.com/ ~ yes, my personal website built purely with tables which needs to be updated heavily Wink

(before i knew anything!)

regia
regia's picture
Offline
Enthusiast
San Diego
Last seen: 3 weeks 5 days ago
San Diego
Timezone: GMT-4
Joined: 2010-10-24
Posts: 307
Points: 347

There are mountains of code

There are mountains of code and divs in there, so I am just giving you a fix that works in FF, I have no idea if it will work in the IE's but it should point you in the right direction.

For 2nd page do the following:
1 - Add overflow: auto to .mybox-wrapper-content

2 - Remove the left bg image from my-title-left and put it on .mytitle and add no-repeat.

3 - To .inner add overflow-y: auto and overflow-x: hidden.

For 1st page just change #2 as above.