11 replies [Last post]
Ed Seedhouse
Ed Seedhouse's picture
Offline
Guru
Victoria British Columbia
Last seen: 20 weeks 3 days ago
Victoria British Columbia
Timezone: GMT-7
Joined: 2005-12-14
Posts: 3570
Points: 675

If I upgrade from Firefox 3.5.8 to 3.6 will my current favorite add-ons cease to function as they did with previous major upgrades? I really hate doing that and my current version work fine.

I must be getting old, I used to jump on every major upgrade with abandon, but I am getting more wary.

Anyway, anyone have experience with this?

Ed Seedhouse

Posting Guidelines

Watch out! I am carrying irony, sarcasm and satire, and know how to use them.

Tags:
Deuce
Deuce's picture
Offline
Guru
Las Vegas, NV
Last seen: 1 year 27 weeks ago
Las Vegas, NV
Timezone: GMT-5
Joined: 2005-11-20
Posts: 4422
Points: 1841

I'm on 3.6 It required an

I'm on 3.6
It required an update on Firebug.
Web Dev Bar seems to work just fine.

I also have ChatZilla, FireFTP, ColorZilla, and others that seem to all work just fine.

Not sure what other plugins you have.

all » http://dictionary.reference.com/browse/all

Google isn't a bunch of guys reading and grading web sites, it's more like a bunch of monkeys sniffing food and putting the good bananas at the top. -Triumph

CupidsToejam
CupidsToejam's picture
Offline
Guru
Florida
Last seen: 20 weeks 1 day ago
Florida
Timezone: GMT-4
Joined: 2008-08-15
Posts: 2636
Points: 1554

Im on 3.6 also. I use Pixel

Im on 3.6 also. I use Pixel Perfect (not sure why I still have that) SenSEO, and YSlow, and they all work.

gary.turner
gary.turner's picture
Offline
Moderator
Dallas
Last seen: 7 hours 10 min ago
Dallas
Timezone: GMT-5
Joined: 2004-06-25
Posts: 9236
Points: 3242

My absolutely, №1, can't

My absolutely, №1, can't function without it addon is Card Games (solitaire). I also have Small Screen Renderer. Neither works on newer versions of Firefox. But, fear not. Install Nightly Tester Tools. So far, I've been able to override all compatibility issues without any hoohah. It's designed for folks who like to run the nightlies.

cheers,

gary

Unplanned code results in a tangled wad of brain-cramping confusion.

There are enough html & css demos and tutorials to be interesting. Please visit.

Eric Watson
Eric Watson's picture
Offline
Regular
Last seen: 4 years 19 weeks ago
Timezone: GMT-7
Joined: 2009-06-29
Posts: 15
Points: 11

A user in another forum

A user in another forum posted that after the upgrade she could no longer preview her site in FX from DW. I work in DW do I'm going to wait.

Hugo
Hugo's picture
Offline
Moderator
London
Last seen: 1 week 2 days ago
London
Timezone: GMT+1
Joined: 2004-06-06
Posts: 15664
Points: 2802

My unfavouratist word in the

My unfavouratist word in the English language is Upgrade

[ Upgrade- verb ]

Synonyms:

Alarm, Anguish, Grief, Despair, Heartache, Stress, Insomnia, palpitations, Hell, Purgatory, Horror, Calamity, Disaster, Catastrophe, Weeping, Sobbing, Crying, Hysteria[maniacal], Panic[attack], Laughing[maniacal][hysterical]

Before you make your first post it is vital that you READ THE POSTING GUIDELINES!
----------------------------------------------------------------
Please post ALL your code - both CSS & HTML - in [code] tags
Please validate and ensure you have included a full Doctype before posting.
Why validate? Read Me

Ed Seedhouse
Ed Seedhouse's picture
Offline
Guru
Victoria British Columbia
Last seen: 20 weeks 3 days ago
Victoria British Columbia
Timezone: GMT-7
Joined: 2005-12-14
Posts: 3570
Points: 675

Thanks for all the advice. I

Thanks for all the advice. I decided to try the upgrade on my laptop and it worked fine, keeping all the add-ons I cared about with no problems.

Since that went well I just did it on my main system and it seems to be fine.

Ed Seedhouse

Posting Guidelines

Watch out! I am carrying irony, sarcasm and satire, and know how to use them.

thepineapplehead
thepineapplehead's picture
Offline
Guru
Milton Keynes
Last seen: 12 weeks 15 hours ago
Milton Keynes
Timezone: GMT+1
Joined: 2004-06-30
Posts: 9668
Points: 801

Most of the problems with

Most of the problems with extensions come from the fact that the install.rdf (iirc) has a maxversion the extension has been tested with and works with. You can change it yourself which in 99% of cases stops the "This addon is not compatible with this version of firefox" - most extension developers are quick to release a new version that works, the only change being a bumped maxversion.

Verschwindende wrote:
  • CSS doesn't make pies

Ed Seedhouse
Ed Seedhouse's picture
Offline
Guru
Victoria British Columbia
Last seen: 20 weeks 3 days ago
Victoria British Columbia
Timezone: GMT-7
Joined: 2005-12-14
Posts: 3570
Points: 675

Thanks for the advice.

Thanks for the advice. Fortunately it doesn't appear necessary to worry further since all the add-ons I was using before work fine with the new version.

Ed Seedhouse

Posting Guidelines

Watch out! I am carrying irony, sarcasm and satire, and know how to use them.

Hugo
Hugo's picture
Offline
Moderator
London
Last seen: 1 week 2 days ago
London
Timezone: GMT+1
Joined: 2004-06-06
Posts: 15664
Points: 2802

I tend to wait to upgrade

I tend to wait to upgrade until I'm sure that Firebug and Web Dev Tools are compatible, and they generally tend to be fairly rapidly if it's even required, but those two extensions oh plus html validator I couldn't function without now

Before you make your first post it is vital that you READ THE POSTING GUIDELINES!
----------------------------------------------------------------
Please post ALL your code - both CSS & HTML - in [code] tags
Please validate and ensure you have included a full Doctype before posting.
Why validate? Read Me

Chris..S
Chris..S's picture
Offline
Moderator
Last seen: 2 years 5 weeks ago
Timezone: GMT+1
Joined: 2005-02-22
Posts: 6078
Points: 173

Although, the prompted update

Although, the prompted update has only been around for a few days, FF3.6 has been out since Jan. If a plugin hasn't been updated by its author already, it probably won't be.

juanpawell
juanpawell's picture
Offline
newbie
Alaska
Last seen: 4 years 28 weeks ago
Alaska
Timezone: GMT+5.5
Joined: 2010-04-15
Posts: 4
Points: 4

I am also using the Fire Fox

I am also using the Fire Fox and the add ons facilities they provided that is so useful to work while and i am using 3.5.2 right now and i do not have any problem while working on that.

Link Removed: User account suspended