1 reply [Last post]
edbarton
Offline
newbie
Last seen: 4 years 34 weeks ago
Joined: 2009-08-19
Posts: 1
Points: 0

In a nutshell I have been developing a wordpress style but unfortunately due to various computer issues (which have now ironically been reversed - macbook failing forcing me onto the PC but that's another issue) haven't been able to bugtest whilst developing in IE. Now I've hit that phase and something very terrible is happening and the site flat out falls apart in IE, although it looks perfect in Firefox for your reference.

I can't really work out what's happening because whilst the source code clearly states that there's a h4 tag and the content div class for the flash players, which floats to the left enabling the sidebar to hug right, that clearly hasn't happened at all. Further inspection on the IE developer thing suggests that IE isn't parsing these at all or something to that effect and neither tag is listed in the body on the HTML tab here.

So my question is what's gone wrong? I really can't imagine it's anything huge, the base style worked in IE, I can't have destroyed it to such a huge extent, but for the life of me I can't work out what I've done and how to solve it.

Any help would be much appreciated.

Thanks in advance

http://blueuniverse.co.uk/client-bangbangs/media/

Tyssen
Tyssen's picture
Offline
Moderator
Brisbane
Last seen: 34 weeks 4 days ago
Brisbane
Timezone: GMT+10
Joined: 2004-05-01
Posts: 8201
Points: 1386

Start by fixing your HTML

Start by fixing your HTML errors. You can't reuse IDs; they have to be unique per page. Every time you want to reuse styles, use classes instead. There's also no name attribute for divs although that's not going to make any difference to your display problems.

How to get help
Post a link. If you can't post a link, jsFiddle it.
My blog | My older articles | CSS Reference